Bug 37488 - Nightly build (2016-1-7) gets System.DllNotFoundException:
Summary: Nightly build (2016-1-7) gets System.DllNotFoundException:
Status: RESOLVED DUPLICATE of bug 41953
Alias: None
Product: Installers
Classification: Mono
Component: General (show other bugs)
Version: 4.2.0 (C6)
Hardware: PC Linux
: Normal normal
Target Milestone: packaging-changes
Assignee: Jo Shields
URL:
Depends on:
Blocks:
 
Reported: 2016-01-07 18:43 UTC by Vince
Modified: 2016-08-30 08:32 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 41953

Description Vince 2016-01-07 18:43:28 UTC
Attempting to get mono working for Corrade ( see my other bug 36513 )
I installed the nightly build.
it generates the following errors:
[vince@desk2 Corrade]$ mono-service --debug Corrade.exe

Unhandled Exception:
System.TypeInitializationException: The type initializer for 'Mono.Unix.Native.Syscall' threw an exception. ---> System.DllNotFoundException: /usr/lib/libMonoPosixHelper.so
  at (wrapper managed-to-native) Mono.Unix.Native.Syscall:get_at_fdcwd ()
  at Mono.Unix.Native.Syscall..cctor () <0x418f3610 + 0x0002b> in <filename unknown>:0 
  --- End of inner exception stack trace ---
  at MonoServiceRunner.Main (System.String[] args) <0x418f1d50 + 0x0037b> in <filename unknown>:0 
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeInitializationException: The type initializer for 'Mono.Unix.Native.Syscall' threw an exception. ---> System.DllNotFoundException: /usr/lib/libMonoPosixHelper.so
  at (wrapper managed-to-native) Mono.Unix.Native.Syscall:get_at_fdcwd ()
  at Mono.Unix.Native.Syscall..cctor () <0x418f3610 + 0x0002b> in <filename unknown>:0 
  --- End of inner exception stack trace ---
  at MonoServiceRunner.Main (System.String[] args) <0x418f1d50 + 0x0037b> in <filename unknown>:0 
[vince@desk2 Corrade]$

Also the older version of mono was able to run the Corrade configurator, this newer version generates the above errors.
Comment 1 Ewan 2016-08-09 11:44:53 UTC
Quick remedy CentOS Linux 7 ...
sudo ln -s /usr/lib64/libMonoPosixHelper.so /usr/lib/libMonoPosixHelper.so
Comment 2 Alex Rønne Petersen 2016-08-29 07:00:40 UTC
I don't think anything has changed in regards to how we build libMonoPosixHelper.so, so I'm assuming this is a packaging bug. Assigning to Jo.
Comment 3 Jo Shields 2016-08-30 08:32:38 UTC

*** This bug has been marked as a duplicate of bug 41953 ***