Bug 37331 - Edited AXML resources in a class library are not recompiled unless you Clean
Summary: Edited AXML resources in a class library are not recompiled unless you Clean
Status: RESOLVED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild (show other bugs)
Version: 5.1
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: dean.ellis
URL:
: 38023 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-12-30 11:58 UTC by Paul Hickman
Modified: 2016-02-17 10:24 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Sample solution to illustrate problem (43.53 KB, application/x-zip-compressed)
2015-12-30 11:58 UTC, Paul Hickman
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Paul Hickman 2015-12-30 11:58:29 UTC
Created attachment 14415 [details]
Sample solution to illustrate problem

If you have an AXML file that is in a library project rather than directly in the application itself, and you:

1. Compile and run the app
2. Stop the app and edit the axml file
3. Compile and run the app

The compiled app will still contain the original unedited AXML resource. You have to do a Build -> Clean Solution before step 3 for the changes to the AXML to be noticed by the compiler.

This occurs in Xamarin Studio and Visual Studio.

Attached is the standard "Hello World" Andoird app with Main.axml moved to a library to illustrate the problem. If you run this, then change the text size of the button it won't have any effect until you clean.
Comment 1 dean.ellis 2016-01-05 15:25:03 UTC
I think this is fixed in our master branch.. Will test the attached project and confirm.
Comment 2 dean.ellis 2016-01-07 14:23:21 UTC
Oddly the updated file makes it into the intermediate directory of the main app.. but it is NOT updating the apk.
Comment 3 dean.ellis 2016-01-27 14:17:51 UTC
I think I tracked down the problem. It was a mistake in the .target files we were using a Property when it should have been an Item when checked the dependencies on the _CreateBaseApk Target. Working on a fix now
Comment 4 dean.ellis 2016-02-17 10:23:51 UTC
Fixed in monodroid/master/189f9787
Comment 5 dean.ellis 2016-02-17 10:24:51 UTC
*** Bug 38023 has been marked as a duplicate of this bug. ***