Bug 37113 - MasterDetailPage swipe gesture doesn't work after IsGestureEnabled is toggled
Summary: MasterDetailPage swipe gesture doesn't work after IsGestureEnabled is toggled
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS (show other bugs)
Version: 2.0.0
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-12-17 01:50 UTC by Drew Lederman
Modified: 2016-04-25 18:17 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Basic Sample (84.21 KB, application/zip)
2016-04-25 18:00 UTC, Momm
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Drew Lederman 2015-12-17 01:50:35 UTC
Steps to reproduce:

1) Create a MasterDetailPage
2) Push a page onto the navigation stack
3) Set IsGestureEnabled to false
4) Pop the page
5) Set IsGestureEnabled to true
6) Swipe gesture no longer opens master page
Comment 1 Gusman 2015-12-17 18:38:37 UTC
Exactly the same problem.

It's not even necessary to push nothing on the stack, just set IsGestureEnabled = false and again IsGestureEnabled = true on the OnPresented function of the page or on any other action and the problem arises.
Comment 2 Drew Lederman 2015-12-17 22:14:58 UTC
Gusman, a workaround was posted on the forums: http://forums.xamarin.com/discussion/comment/171437/#Comment_171437
Comment 3 Momm 2016-02-25 19:43:58 UTC
When you gonna fix it? It's really annoying to have to use that workaround.
Comment 4 Rui Marinho 2016-03-03 12:44:52 UTC
Should be fixed in 2.2.0-pre1
Comment 5 Momm 2016-03-03 12:47:20 UTC
Please pay attention to iPads with iOS 7, because I had to implement another workaround inheriting from TabletMasterDetailRenderer to make it work in this version.
Comment 6 Parmendra Kumar 2016-04-25 14:56:09 UTC
@Drew Lederman, To verify this issue I have tried to reproduce it but not able to reproduce this issue.
Could you please provide us sample project so that I can verify this issue efficiently.
Comment 7 Momm 2016-04-25 18:00:32 UTC
Created attachment 15833 [details]
Basic Sample
Comment 8 Momm 2016-04-25 18:17:19 UTC
When using XF 2.2-pre4 it's not working on iPads with iOS7, but it's working on IPads with iOS8.