Bug 37043 - Xamarin Studio hangs for 20 seconds every few minutes
Summary: Xamarin Studio hangs for 20 seconds every few minutes
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor (show other bugs)
Version: 5.10 (C6SR3)
Hardware: PC Mac OS
: High normal
Target Milestone: C6SR2
Assignee: Mike Krüger
URL:
: 38082 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-12-15 21:29 UTC by Cody Beyer (MSFT)
Modified: 2016-07-05 12:23 UTC (History)
15 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
spinning wheel during coding - logs attached Feb 4 is most recent occurrence (23.76 KB, application/zip)
2016-02-04 15:50 UTC, Neal
Details
Feb 12 logs - major delays using Android (204.84 KB, application/zip)
2016-02-12 18:02 UTC, Neal
Details
More intellisense delays / spinning wheel on Mac (147.36 KB, application/zip)
2016-02-24 21:03 UTC, Neal
Details
More hangs - office computer Feb 25 (53.43 KB, application/zip)
2016-02-25 19:02 UTC, Neal
Details
happening again (397.67 KB, application/zip)
2016-03-15 00:52 UTC, Neal
Details

Description Cody Beyer (MSFT) 2015-12-15 21:29:42 UTC
### Description

The following logs are from a Xamarin Studio installation that is reported to hang every few minutes, for 10-20 seconds. 

### Sys Info

https://db.tt/HX22gq9d

### Logs

https://www.dropbox.com/s/ipt6q9sintiif0m/Archive.zip?dl=0

### Versions

=== Xamarin Studio ===

Version 5.10.2 (build 26)
Installation UUID: 4cd497ab-56ce-49e1-9edc-9cbb5f2a4d16
Runtime:
	Mono 4.2.1 (explicit/39edf24)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 402010124

=== Xamarin.Profiler ===

Not Installed

=== Xamarin.Android ===

Version: 6.0.0.41 (Business Edition)
Android SDK: /Users/codybeyer/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		4.0.3 (API level 15)
		4.4   (API level 19)
		6.0   (API level 23)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.0.1
SDK Build Tools Version: 23.0.1

Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

=== Xamarin Android Player ===

Version: 0.6.5
Location: /Applications/Xamarin Android Player.app

=== Apple Developer Tools ===

Xcode 7.2 (9548)
Build 7C68

=== Xamarin.iOS ===

Version: 9.4.1.0 (Business Edition)
Hash: dab1554
Branch: master
Build date: 2015-12-08 23:32:56-0500

=== Xamarin.Mac ===

Version: 2.4.0.112 (Business Edition)

=== Build Information ===

Release ID: 510020026
Git revision: 33a8642aa88f9119949cce312b9186308d8ca76c
Build date: 2015-12-07 17:21:45-05
Xamarin addins: af8ffe5b187898ec2f2f0c78de1bd01ae39b2008
Build lane: monodevelop-lion-cycle6

=== Operating System ===

Mac OS X 10.11.2
Comment 1 Brendan Zagaeski (Xamarin Team, assistant) 2015-12-15 21:40:01 UTC
This might be related to Bug 36333. If so, disabling source analysis might help as a temporary workaround.
Comment 3 Matt Ward 2015-12-15 23:05:27 UTC
Disabling source analysis is a good thing to try first.

I cannot see anything in the logs.

I am assuming we are talking about a UI freeze here. If Xamarin Studio is hanging it would be useful to capture a thread stack dump when it is hung. You can do that by finding the process id for Xamarin Studio using Activity Monitor, then when it hangs run the following from a terminal window:

    kill -QUIT pid

Replacing pid with the process id for Xamarin Studio. That will cause Xamarin Studio to log the current stack traces to its IDE log (Help - Open Log Directory). We should be able to see from that where the UI is hanging.

Running kill quit will not close Xamarin Studio but you should consider it to be in an unstable state after running this command so you will want to restart it.
Comment 4 Robert Altland 2016-01-04 18:51:32 UTC
Yes, UI freeze. I did have source analysis enabled. When I disabled it I experienced no change. Ill try to capture a dump when this occurs, but the freeze is frequent but relatively short.
Comment 5 Robert Altland 2016-01-04 23:25:21 UTC
Heres a link to an archive containing log files created from killing the app. I wasn't sure if the additional log files would be useful, but I included them anyway.
http://bit.ly/1O7d39n
Comment 6 Matt Ward 2016-01-05 09:38:16 UTC
Looking at the stack dumps if the UI is locked then it seems to be that Xamarin Studio is trying to get some information about iOS device on the UI Thread using IPhoneDevice.AMDeviceCopyValue. If this is happening every few minutes then it would suggest that Xamarin Studio is refreshing its device information every few minutes since it believes it has changed.

For Xamarin Studio 5.10 the only thing I can think of to suggest to work around the problem for now is that you try disconnecting your iOS devices from your machine to see if it makes any difference. This is not going to be that helpful if you are writing code and deploying to the iOS device frequently.

This particular problem has reported on the forum:

http://forums.xamarin.com/discussion/comment/170927/

I was sent the IDE log from the above forum post in a private message and it seems to have the same callstack on the UI thread.
Comment 7 Robert Altland 2016-01-05 17:28:30 UTC
That's odd, these hangs happen even when I have no devices connected. I sync my devices over wifi in iTunes, is it possible that Xamarin Studio is seeing my devices over wifi? Would it do this with simulators? I'll capture more logs today as I work. Im not sure that will help you, but Ill do it just in case there could be something else contributing to the hang.
Comment 8 Matt Ward 2016-01-05 17:48:54 UTC
Looking at the callstack this is for a device and not a simulator. The device should be showing up in the main toolbar in the drop down list.
Comment 9 Robert Altland 2016-01-05 21:26:59 UTC
Here's a new archive of log files. I cleared the directory so these are only for today. I didn't have any devices plugged in. http://bit.ly/1JW4pbS
Comment 10 Matt Ward 2016-01-06 18:48:33 UTC
Thanks. The thread callstack in the new logs is the same as before with the UI thread hanging when calling IPhoneDevice.AMDeviceCopyValue:

2016-01-05 12:06:01Z

"GUI Thread"  
  at Xamarin.MacDev.IPhoneDevice.AMDeviceCopyValue (intptr,intptr,intptr)
  at Xamarin.MacDev.IPhoneDevice.GetDeviceString (Xamarin.MacDev.CFString)
Comment 11 Robert Altland 2016-01-06 19:01:14 UTC
OK, I think its good that my hang has a consistent cause, but I didn't have any devices plugged in at all yesterday. Is there some other condition that would cause Xamarin Studio to think it needs to call this? Is there anything more you need from me to help troubleshoot this?
Comment 12 Matt Ward 2016-01-07 18:16:54 UTC
Looking at the code the device information seems to be read if either the currently active configuration is not for a simulator or if an info.plist file cannot be found.

I don't think we need anything else from you.

The fix will probably be to ensure that the AMDeviceCopyValue method is not called on the UI thread if it may take a long time to complete.
Comment 13 Jeffrey Stedfast 2016-01-12 21:51:29 UTC
it's an instantaneous call (which is why it almost always returns null), so that's not the problem.
Comment 20 Jeffrey Stedfast 2016-01-14 20:30:10 UTC
Do you have (presumably multiple?) iOS devices connected to your machine via wifi sync?
Comment 21 xamarin-release-manager 2016-01-14 21:45:45 UTC
Fixed in version 6.0.0.2933 (master)

Author: Jeffrey Stedfast
Commit: 66614e3059a380be94d11763ed7778e0072dc6ea (xamarin/maciostools)
Included in Commit: e8b107c7618b216c6ca34868eecb24c60f43a88f (mono/monodevelop)
Comment 22 Robert Altland 2016-01-18 20:00:50 UTC
Yes, I do have multiple iOS devices connected via wifi sync. I have verified that if I turn off wifi, the hesitation is still there but hardly noticeable. The mouse hesitates for about a second and frees back up. This is a tolerable hesitation, but working disconnected isn't really an option. I suppose I could turn off wifi sync for all my devices and that may have the same effect. I'll give that a shot. How can I get my hands on the fix? I've checked the alpha channel and XS is at v 5.10.2 (assuming the fix is to Xamarin Studio).
Comment 24 Jeffrey Stedfast 2016-01-26 16:49:42 UTC
Seems more like the problem is mtouch crashing:

ERROR [2016-01-25 16:43:28Z]: Failed to query list of simulators.
System.Xml.XmlException: Root element is missing.
  at System.Xml.XmlTextReaderImpl.Throw (System.Exception e) [0x0002a] in /private/tmp/source-mono-mac-4.2.0-branch/bockbuild-mono-4.2.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.2.1/external/referencesource/System.Xml/System/Xml/Core/XmlTextReaderImpl.cs:2498 
  at System.Xml.XmlTextReaderImpl.ThrowWithoutLineInfo (System.String res) [0x00000] in /private/tmp/source-mono-mac-4.2.0-branch/bockbuild-mono-4.2.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.2.1/external/referencesource/System.Xml/System/Xml/Core/XmlTextReaderImpl.cs:2506 
  at System.Xml.XmlTextReaderImpl.ParseDocumentContent () [0x0041e] in /private/tmp/source-mono-mac-4.2.0-branch/bockbuild-mono-4.2.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.2.1/external/referencesource/System.Xml/System/Xml/Core/XmlTextReaderImpl.cs:3738 
  at System.Xml.XmlTextReaderImpl.Read () [0x00097] in /private/tmp/source-mono-mac-4.2.0-branch/bockbuild-mono-4.2.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.2.1/external/referencesource/System.Xml/System/Xml/Core/XmlTextReaderImpl.cs:1163 
  at System.Xml.Linq.XDocument.Load (System.Xml.XmlReader reader, LoadOptions options) [0x0001c] in /private/tmp/source-mono-mac-4.2.0-branch/bockbuild-mono-4.2.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.2.1/external/referencesource/System.Xml.Linq/System/Xml/Linq/XLinq.cs:5728 
  at System.Xml.Linq.XDocument.Load (System.IO.TextReader textReader, LoadOptions options) [0x0000f] in /private/tmp/source-mono-mac-4.2.0-branch/bockbuild-mono-4.2.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.2.1/external/referencesource/System.Xml.Linq/System/Xml/Linq/XLinq.cs:5691 
  at System.Xml.Linq.XDocument.Load (System.IO.TextReader textReader) [0x00000] in /private/tmp/source-mono-mac-4.2.0-branch/bockbuild-mono-4.2.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.2.1/external/referencesource/System.Xml.Linq/System/Xml/Linq/XLinq.cs:5664 
  at Xamarin.MacDev.AppleIPhoneSdk+<GetSimulatorTargets>c__Iterator0.MoveNext () [0x00110] in /Users/fejj/src/md-addins/external/maciostools/Xamarin.MacDev/Encrypted/AppleIPhoneSdk.cs:133 
Stacktrace:

  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) MonoMac.ObjCRuntime.Class.class_addMethod (intptr,intptr,intptr,string) <0xffffffff>
  at MonoMac.ObjCRuntime.Class.RegisterMethod (System.Reflection.MethodInfo,MonoMac.Foundation.ExportAttribute,System.Type,intptr) <0x0010c>
  at MonoMac.ObjCRuntime.Class.RegisterMethod (System.Reflection.MethodInfo,System.Type,intptr) <0x00119>
  at MonoMac.ObjCRuntime.Class.Register (System.Type,string,bool) <0x006a7>
  at MonoMac.ObjCRuntime.Class.Register (System.Type) <0x000df>
  at MonoMac.ObjCRuntime.Runtime.RegisterAssembly (System.Reflection.Assembly) <0x003eb>
  at Xamarin.Hosting.Services.Initialize (string,bool) <0x0004e>
  at MonoTouch.Simulator.SimController.Initialize () <0x00046>
  at MonoTouch.Simulator.SimController.ListSimulators (string) <0x0008a>
  at MTouch.Main2 (string[]) <0x0662c>
  at MTouch.Main (string[]) <0x00069>
  at (wrapper runtime-invoke) <Module>.runtime_invoke_int_object (object,intptr,intptr,intptr) <0xffffffff>

Native stacktrace:


=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.
=================================================================

ERROR [2016-01-25 16:43:28Z]: Failed to query list of simulators.
System.Xml.XmlException: Root element is missing.
  at System.Xml.XmlTextReaderImpl.Throw (System.Exception e) [0x0002a] in /private/tmp/source-mono-mac-4.2.0-branch/bockbuild-mono-4.2.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.2.1/external/referencesource/System.Xml/System/Xml/Core/XmlTextReaderImpl.cs:2498 
  at System.Xml.XmlTextReaderImpl.ThrowWithoutLineInfo (System.String res) [0x00000] in /private/tmp/source-mono-mac-4.2.0-branch/bockbuild-mono-4.2.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.2.1/external/referencesource/System.Xml/System/Xml/Core/XmlTextReaderImpl.cs:2506 
  at System.Xml.XmlTextReaderImpl.ParseDocumentContent () [0x0041e] in /private/tmp/source-mono-mac-4.2.0-branch/bockbuild-mono-4.2.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.2.1/external/referencesource/System.Xml/System/Xml/Core/XmlTextReaderImpl.cs:3738 
  at System.Xml.XmlTextReaderImpl.Read () [0x00097] in /private/tmp/source-mono-mac-4.2.0-branch/bockbuild-mono-4.2.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.2.1/external/referencesource/System.Xml/System/Xml/Core/XmlTextReaderImpl.cs:1163 
  at System.Xml.Linq.XDocument.Load (System.Xml.XmlReader reader, LoadOptions options) [0x0001c] in /private/tmp/source-mono-mac-4.2.0-branch/bockbuild-mono-4.2.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.2.1/external/referencesource/System.Xml.Linq/System/Xml/Linq/XLinq.cs:5728 
  at System.Xml.Linq.XDocument.Load (System.IO.TextReader textReader, LoadOptions options) [0x0000f] in /private/tmp/source-mono-mac-4.2.0-branch/bockbuild-mono-4.2.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.2.1/external/referencesource/System.Xml.Linq/System/Xml/Linq/XLinq.cs:5691 
  at System.Xml.Linq.XDocument.Load (System.IO.TextReaer textReader) [0x00000] in /private/tmp/source-mono-mac-4.2.0-branch/bockbuild-mono-4.2.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.2.1/external/referencesource/System.Xml.Linq/System/Xml/Linq/XLinq.cs:5664 
  at Xamarin.MacDev.AppleIPhoneSdk+<GetSimulatorTargets>c__Iterator0.MoveNext () [0x00110] in /Users/fejj/src/md-addins/external/maciostools/Xamarin.MacDev/Encrypted/AppleIPhoneSdk.cs:133
Comment 25 Rolf Bjarne Kvinge [MSFT] 2016-01-26 19:11:59 UTC
@Jeff, which XI version was used to get the output from comment #24?
Comment 26 Lluis Sanchez 2016-01-27 09:18:14 UTC
*** Bug 38082 has been marked as a duplicate of this bug. ***
Comment 27 Alan McGovern 2016-01-27 09:45:46 UTC
I trigger it without mtouch crashing and without any devices attached. It must not be an instantaneous call, but we could add logging to verify that. See bug #38082
Comment 30 Rolf Bjarne Kvinge [MSFT] 2016-01-27 10:59:04 UTC
You should not do any AMDevice calls on the main thread, those may synchronously connect to the device, and that can take an unbound amount of time (it'll become even worse if you have any watches connected).
Comment 31 Jeffrey Stedfast 2016-01-27 11:59:07 UTC
@Rolf: that was with git master of XI

@Alan,@Rolf: we can't put that code in another thread. We tried that before and got crashes. That code *must* run in the main thread.
Comment 32 Jeffrey Stedfast 2016-01-27 12:00:29 UTC
Also note that that code has existed for 5 years running on the main thread (except for a short stint running in another thread where it crashed all the time) and no one until now(?) has ever had these 20s hangs.

Why?
Comment 33 Rolf Bjarne Kvinge [MSFT] 2016-01-27 12:04:26 UTC
Xcode does not run that code on the main thread, so I doubt that was the real reason for the crashes.
Comment 34 Jeffrey Stedfast 2016-01-27 13:40:29 UTC
That doesn't explain why no one has seen these hangs before.
Comment 35 Jeffrey Stedfast 2016-01-27 18:45:26 UTC
I've moved this logic into another thread. Hopefully we won't get crashes like last time. *fingers crossed*
Comment 37 Neal 2016-02-04 15:50:00 UTC
Created attachment 14898 [details]
spinning wheel during coding - logs attached Feb 4 is most recent occurrence
Comment 38 Neal 2016-02-04 15:50:24 UTC
I'm still struggling with this issue and attached my logs.

=== Xamarin Studio ===

Version 5.10.2 (build 56)
Installation UUID: 93bdb3c9-7b71-482a-86ba-69afd1ffd0e7
Runtime:
	Mono 4.2.2 (explicit/996df3c)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 402020030

=== Xamarin.Profiler ===

Not Installed

=== Apple Developer Tools ===

Xcode 7.2.1 (9548.1)
Build 7C1002

=== Xamarin.Mac ===

Version: 2.4.1.6 (Business Edition)

=== Xamarin.iOS ===

Version: 9.4.1.25 (Business Edition)
Hash: 962a050
Branch: master
Build date: 2016-01-29 16:59:11-0500

=== Xamarin.Android ===

Version: 6.0.1.10 (Business Edition)
Android SDK: /Users/Neal/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.4   (API level 19)
		5.1   (API level 22)
		6.0   (API level 23)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.1
SDK Build Tools Version: 23.0.2

Java SDK: /Library/Java/JavaVirtualMachines/jdk1.8.0_31.jdk/Contents/Home
java version "1.8.0_31"
Java(TM) SE Runtime Environment (build 1.8.0_31-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.31-b07, mixed mode)

=== Xamarin Android Player ===

Not Installed

=== Build Information ===

Release ID: 510020056
Git revision: bb74ff467c62ded42b7b7ac7fdd2edc60f8647b0
Build date: 2016-01-26 16:24:41-05
Xamarin addins: 8b797d7ba24d5abab226c2cf9fda77f666263f1b
Build lane: monodevelop-lion-cycle6-c6sr1

=== Operating System ===

Mac OS X 10.11.3
Darwin NEALs-iMacR.local 15.3.0 Darwin Kernel Version 15.3.0
    Thu Dec 10 18:40:58 PST 2015
    root:xnu-3248.30.4~1/RELEASE_X86_64 x86_64
Comment 39 Neal 2016-02-12 18:02:30 UTC
Created attachment 15024 [details]
Feb 12 logs - major delays using Android
Comment 40 Neal 2016-02-12 18:03:57 UTC
I'm seeing a lot of issues still with Jeff's custom build of XS he sent me via the forums.  I'm working on Android now and seeing major delays with the Mac spinning wheel such as when typing code and entering += or an open paren ( and even sometimes typing a semi-colon at the end of the line.  kill -QUIT pid doesn't stop it either.  I attached updated logs for your review.

=== Xamarin Studio ===

Version 5.10.3 (build 14)
Installation UUID: 93bdb3c9-7b71-482a-86ba-69afd1ffd0e7
Runtime:
	Mono 4.2.2 (explicit/996df3c)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 402020030

=== Xamarin.Profiler ===

Not Installed

=== Apple Developer Tools ===

Xcode 7.2.1 (9548.1)
Build 7C1002

=== Xamarin.Mac ===

Version: 2.4.1.6 (Business Edition)

=== Xamarin.iOS ===

Version: 9.4.1.25 (Business Edition)
Hash: 962a050
Branch: master
Build date: 2016-01-29 16:59:11-0500

=== Xamarin.Android ===

Version: 6.0.1.10 (Business Edition)
Android SDK: /Users/Neal/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.4   (API level 19)
		5.0   (API level 21)
		5.1   (API level 22)
		6.0   (API level 23)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.1
SDK Build Tools Version: 23.0.2

Java SDK: /Library/Java/JavaVirtualMachines/jdk1.8.0_31.jdk/Contents/Home
java version "1.8.0_31"
Java(TM) SE Runtime Environment (build 1.8.0_31-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.31-b07, mixed mode)

=== Xamarin Android Player ===

Not Installed

=== Build Information ===

Release ID: 510030014
Git revision: 0d40d692177e240b28e9c18e4f56b8fffa28268c
Build date: 2016-02-03 11:36:50-05
Xamarin addins: 2d840b1de5d7161a18abed40e5a06fd79a7684d3
Build lane: monodevelop-lion-device-hang-fix

=== Operating System ===

Mac OS X 10.11.3
Darwin NEALs-iMacR.local 15.3.0 Darwin Kernel Version 15.3.0
    Thu Dec 10 18:40:58 PST 2015
    root:xnu-3248.30.4~1/RELEASE_X86_64 x86_64
Comment 41 Jeffrey Stedfast 2016-02-12 18:54:30 UTC
Unfortunately I'm not seeing any hangs in the GUI Thread in the logs.

One of the logs (on Feb 10th) has a segfault which someone should look at and some of the others have a lot of unhandled exceptions in the Android and/or TextEditor areas, but no hangs in the kill -QUIT stack dumps.

Based on Neal's description, I'd guess it was hangs in the TextEditor but I'm just guessing.
Comment 42 Mike Krüger 2016-02-12 19:01:00 UTC
The logs don't tell anything however what's with the memory usage ?

I suspect we may see a memory problem here.
Comment 43 Neal 2016-02-12 19:36:51 UTC
I'll try to get you some memory numbers next time I see this.  Yes, I've had about a half dozen Xam Studio crashes between office and home iMacs (identical setups), no real pattern as to when/why it happens.  All of the sudden I'll get the password prompt from Mac OS for dev tools so I know the crash is coming then it's gone.
Comment 44 PJ 2016-02-18 22:03:07 UTC
Looks like this is not necessarily resolved, so I'm REOPENING it to track getting more info from Neal and getting to the root cause. 

It is also not making the C6SR2 release (which is going to be a very tiny release), so updating milestone to C7.
Comment 45 Mike Krüger 2016-02-19 06:36:59 UTC
5.x and 6.x is very different - it's basically another IDE with some shared code
Comment 46 Neal 2016-02-21 14:39:17 UTC
In the past few days this has not reared its ugly head, i.e. no issues, with XS 6 on the horizon I suggest closing this out and if I see any major annoyances and have info for you I will certainly let you know.
Comment 47 Neal 2016-02-24 21:03:52 UTC
Created attachment 15165 [details]
More intellisense delays / spinning wheel on Mac
Comment 48 Neal 2016-02-24 21:05:19 UTC
Working on the home iMac today which I have typically not had a problem with in the past.  Today working in a major iOS project and I'm having delay after delay (spinning wheel) with Intellisense.  I only did a kill -QUIT once, they typically clear pretty fast after 3-5 seconds but just an annoyance.  Hope the logs can show something.

=== Xamarin Studio ===

Version 5.10.3 (build 14)
Installation UUID: 73513e37-5013-428d-8378-0897497f2380
Runtime:
	Mono 4.2.2 (explicit/996df3c)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 402020030

=== Xamarin.Profiler ===

Not Installed

=== Apple Developer Tools ===

Xcode 7.2.1 (9548.1)
Build 7C1002

=== Xamarin.Mac ===

Version: 2.4.1.6 (Business Edition)

=== Xamarin.iOS ===

Version: 9.4.1.25 (Business Edition)
Hash: 962a050
Branch: master
Build date: 2016-01-29 16:59:11-0500

=== Xamarin.Android ===

Version: 6.0.1.10 (Business Edition)
Android SDK: /Users/Neal/Applications/android-sdk-macosx
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.4   (API level 19)
		5.0   (API level 21)
		5.1   (API level 22)
		6.0   (API level 23)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.1
SDK Build Tools Version: 23.0.1

Java SDK: /usr
java version "1.8.0_40"
Java(TM) SE Runtime Environment (build 1.8.0_40-b25)
Java HotSpot(TM) 64-Bit Server VM (build 25.40-b25, mixed mode)

=== Xamarin Android Player ===

Not Installed

=== Build Information ===

Release ID: 510030014
Git revision: 0d40d692177e240b28e9c18e4f56b8fffa28268c
Build date: 2016-02-03 11:36:50-05
Xamarin addins: 2d840b1de5d7161a18abed40e5a06fd79a7684d3
Build lane: monodevelop-lion-device-hang-fix

=== Operating System ===

Mac OS X 10.11.3
Darwin iMACRH.local 15.3.0 Darwin Kernel Version 15.3.0
    Thu Dec 10 18:40:58 PST 2015
    root:xnu-3248.30.4~1/RELEASE_X86_64 x86_64
Comment 49 Neal 2016-02-24 21:05:56 UTC
Memory is not an issue on this iMac, 32 GB of RAM and I use iStats Menu and I'm not seeing anything of interest in memory pressure, etc.
Comment 52 Neal 2016-02-25 19:02:15 UTC
Created attachment 15172 [details]
More hangs - office computer Feb 25
Comment 53 Neal 2016-02-25 19:04:35 UTC
And today I'm suffering big time with this, constant serious annoyance of delays.  Office computer today, iOS project which includes extensions (safari and watch) and about a dozen total class libraries.  I did the kill -QUIT a few times but it's not always effective.  I tried turning off code suggestions and code analysis and that seemed to help.  I think this is in the code suggestions area and not code analysis causing this.  I tried code suggestions on with analysis off and it still happened.  I have now reverted back to 10.2 (latest stable) as 10.3 wasn't really helping much.  Hope you can do something as it's counter productive big time.

Thanks.
Comment 55 Jeffrey Stedfast 2016-02-25 19:24:33 UTC
Reassigning to TextEditor I guess? I have no idea what the hang is. Nothing is showing up in the logs.
Comment 56 Alan McGovern 2016-02-25 20:41:20 UTC
He current alpha builds will either give us better output when these hangs happen, and you do the kill -Quit invocation, or they could fix the issue you're hitting. 

It would be great if you could try mono 4.4+ builds And/or Xamarin Stuidio 6.x builds.
Comment 57 Neal 2016-02-25 20:47:25 UTC
I was thinking about giving ALPHA a try. The kill -QUIT does not instantly remedy the issue.  I'll let you know if I try alpha and see if it helps.
Comment 58 Brendan Zagaeski (Xamarin Team, assistant) 2016-02-25 21:08:46 UTC
Just for extra information `kill -QUIT` is a way to cause Xamarin Studio to dump out the managed stack traces for all currently running threads into the log file. It would not be expected to reduce pausing behavior, but rather provide stack traces in the logs that would help diagnose the root cause of the pauses.
Comment 59 Jeffrey Stedfast 2016-03-07 18:09:06 UTC
This should be fixed now.
Comment 61 Neal 2016-03-15 00:52:29 UTC
Created attachment 15401 [details]
happening again
Comment 62 Neal 2016-03-15 00:53:01 UTC
Haven't had any problems on new stables for days, tonight it's started again!  Log files attached, look at this evening session on March 14

=== Xamarin Studio ===

Version 5.10.3 (build 26)
Installation UUID: 73513e37-5013-428d-8378-0897497f2380
Runtime:
	Mono 4.2.3 (explicit/832de4b)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 402030004

=== Xamarin.Profiler ===

Not Installed

=== Apple Developer Tools ===

Xcode 7.2.1 (9548.1)
Build 7C1002

=== Xamarin.Mac ===

Version: 2.4.1.7 (Business Edition)

=== Xamarin.iOS ===

Version: 9.4.2.27 (Business Edition)
Hash: 58ba2bc
Branch: master
Build date: 2016-03-03 09:05:19-0500

=== Xamarin.Android ===

Version: 6.0.2.1 (Business Edition)
Android SDK: /Users/Neal/Applications/android-sdk-macosx
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.4   (API level 19)
		5.0   (API level 21)
		5.1   (API level 22)
		6.0   (API level 23)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.1
SDK Build Tools Version: 23.0.2

Java SDK: /usr
java version "1.8.0_40"
Java(TM) SE Runtime Environment (build 1.8.0_40-b25)
Java HotSpot(TM) 64-Bit Server VM (build 25.40-b25, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Android Player ===

Not Installed

=== Build Information ===

Release ID: 510030026
Git revision: ac9b7fcba9ee92ac30c8eb90f20c2228ce033efa
Build date: 2016-03-01 18:02:09-05
Xamarin addins: 633fde3bf405e3c402a51980976c431c204cf4f6
Build lane: monodevelop-lion-cycle6-c6sr2

=== Operating System ===

Mac OS X 10.11.3
Darwin iMACRH.local 15.3.0 Darwin Kernel Version 15.3.0
    Thu Dec 10 18:40:58 PST 2015
    root:xnu-3248.30.4~1/RELEASE_X86_64 x86_64

Note You need to log in before you can comment on or make changes to this bug.