Bug 36774 - UnhandledException publishing AdHoc build iTunesMetadata.plist already exists
Summary: UnhandledException publishing AdHoc build iTunesMetadata.plist already exists
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in (show other bugs)
Version: 5.10 (C6SR3)
Hardware: PC Mac OS
: --- normal
Target Milestone: C6SR2
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2015-12-09 16:09 UTC by John Miller [MSFT]
Modified: 2016-03-03 15:16 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description John Miller [MSFT] 2015-12-09 16:09:26 UTC
**Overview:**

   Xamarin Studio throws an unhandled exception while trying to publish an AdHoc build. 

**Steps to Reproduce:**

   Unable to reproduce in my environment. 

**Actual Results:**

   See attached logs for full stack trace.

>FATAL ERROR [2015-12-08 23:38:20Z]: An unhandled exception has occured. Terminating Xamarin Studio? True
>System.AggregateException: One or more errors occurred. ---> System.IO.IOException: /var/folders/jg/c232s2h95f9576jqzvgtsm000000gn/T/mdTmpDir2061006485/iTunesMetadata.plist already exists

**Expected Results:**

   No exceptions. 

**Build Date & Platform:**

=== Xamarin Studio ===

Version 5.10.1 (build 6)
Installation UUID: b6932faf-ccfd-4324-a7ed-e11a8199cde9
Runtime:
Mono 4.2.1 (explicit/6dd2d0d)
GTK+ 2.24.23 (Raleigh theme)

Package version: 402010102

=== Xamarin.Profiler ===

Version: 0.18.0.0
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Apple Developer Tools ===

Xcode 7.1.1 (9081)
Build 7B1005

=== Xamarin.iOS ===

Version: 9.2.1.54 (Business Edition)
Hash: eb4c1ef
Branch: master
Build date: 2015-12-01 02:12:30-0500

=== Xamarin.Android ===

Version: 6.0.0.34 (Starter Edition)
Android SDK:
/Users/ignaciomachin/Library/Developer/Xamarin/android-sdk-mac_x86
Supported Android versions:
2.3 (API level 10)
4.0.3 (API level 15)

SDK Tools Version: 22.3
SDK Platform Tools Version: 19.0.0
SDK Build Tools Version: 17.0.0

Java SDK: /usr
java version "1.8.0_65"
Java(TM) SE Runtime Environment (build 1.8.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 25.65-b01, mixed mode)

=== Xamarin Android Player ===

Not Installed

=== Xamarin.Mac ===

Not Installed

=== Build Information ===

Release ID: 510010006
Git revision: 0b60eecdb531933734519c13257d16a780274aab
Build date: 2015-12-04 20:28:20-05
Xamarin addins: 9876fd7c9837977178411ec7375b4352c0a0d6af
Build lane: monodevelop-lion-cycle6-baseline

=== Operating System ===

Mac OS X 10.11.1
Comment 3 Jeffrey Stedfast 2016-01-25 18:05:09 UTC
Fixed
Comment 7 xamarin-release-manager 2016-02-26 19:49:38 UTC
Fixed in version 5.10.3.19 (cycle6)

Author: Greg Munn
Commit: 96635e4c6f48b8c5d2001e6b0faeea4cd9f017be (xamarin/md-addins)
Included in Commit: 8dfff81c44e8bc8edb9e797e19c9dfb145754931 (mono/monodevelop)