Bug 3675 - MD git diffs and commits incorrectly on windows
Summary: MD git diffs and commits incorrectly on windows
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Version Control (show other bugs)
Version: Trunk
Hardware: PC Windows
: High major
Target Milestone: master
Assignee: Marius Ungureanu
URL:
: 21437 (view as bug list)
Depends on:
Blocks: 3616
  Show dependency tree
 
Reported: 2012-02-28 19:27 UTC by Mikayla Hutchinson [MSFT]
Modified: 2015-08-20 03:23 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Mikayla Hutchinson [MSFT] 2012-02-28 19:27:29 UTC
MonoDevelop doesn't respect .gitattributes for line ending handling, which means that for projects that depend on it heavily, suxh as MD itself, it incorrectly shows many files as 100% modified. Changes to such files would be committed incorrectly, which is a major issue.
Comment 1 Marius Ungureanu 2013-11-19 20:53:30 UTC
This is a limitation in NGit. Not fixable on our side, needs to be resolved upstream.
Comment 2 Marius Ungureanu 2013-11-21 00:38:24 UTC
It depends on https://bugzilla.xamarin.com/show_bug.cgi?id=9917
Comment 3 Marius Ungureanu 2013-11-26 11:33:18 UTC
Also added https://bugs.eclipse.org/bugs/show_bug.cgi?id=301775
Comment 4 Marius Ungureanu 2014-03-04 11:18:59 UTC
It will be fixed when we merge ikvmJGit branch into master.
Comment 5 Marius Ungureanu 2014-07-18 10:14:03 UTC
*** Bug 21437 has been marked as a duplicate of this bug. ***
Comment 6 David Naylor 2014-07-21 02:01:12 UTC
Is this bug resolved?  I am still getting this issue with Xamarin 5.1.4 (as per duplicate bug 21437).
Comment 7 Marius Ungureanu 2014-07-21 10:12:22 UTC
This will come in a future release. we haven't yet switched to the new git provider.
Comment 8 Parmendra Kumar 2015-05-05 13:49:22 UTC
@Marius

I have checked this issue and observed that after commit, all changes is successfully updated to git.
Could you please let me know if I have to check anything else to verify this issue? 


Thanks.
Comment 9 Marius Ungureanu 2015-05-05 13:51:54 UTC
You need to:

1. Checkout a repository.
2. Modify files in it.
3. Verify that when opening the files and switching to the Changes panel at the bottom of the document, only the changed lines are colored, not the whole file.
Comment 10 Parmendra Kumar 2015-05-05 13:55:50 UTC
Thanks @Marius

I have recheck this issue as per comment#9 and Its working fine.

Hence closing this issue.

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.


Create a new report for Bug 3675 on Developer Community or GitHub if you have new information to add and do not yet see a matching report.

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments


Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Related Links: