Bug 36543 - [XVS 4.0] "Disallowed paths ( "iTunesMetadata.plist" ) found" or "Disallowed paths ( "iTunesArtwork" ) found" when using Xamarin 4
Summary: [XVS 4.0] "Disallowed paths ( "iTunesMetadata.plist" ) found" or "Disallowed ...
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS (show other bugs)
Version: 4.0.0 (C6)
Hardware: PC Windows
: --- normal
Target Milestone: 4.0.1 (C6SR1)
Assignee: Bugzilla
URL:
: 37645 (view as bug list)
Depends on: 36060
Blocks:
  Show dependency tree
 
Reported: 2015-12-03 16:50 UTC by Brendan Zagaeski (Xamarin Team, assistant)
Modified: 2016-01-14 22:20 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Brendan Zagaeski (Xamarin Team, assistant) 2015-12-03 16:50:11 UTC
[XVS 4.0] "Disallowed paths ( "iTunesMetadata.plist" ) found" or "Disallowed paths ( "iTunesArtwork" ) found" when using Xamarin 4

This is an intentional duplicate public bug report to improve Bugzilla searchability for the latest cause of these 2 errors in Xamarin 4.



## Possible workarounds

### Option 1: edit the `.csproj` file by hand to set the `IpaIncludeArtwork` property to false

Find the `<PropertyGroup Condition=" '$(Configuration)|$(Platform)'` section that matches the configuration your using to build the IPA, and add the following line within that section:

<IpaIncludeArtwork>False</IpaIncludeArtwork>




### Option 2: Remove the `iTunesMetadata.plist` file from the `.ipa` file by hand before submitting it

The `.ipa` file is just a ZIP archive. For this bug, the problematic file is located under in the root of the zip file.

So to remove the file:

1. Unzip the `.ipa` file (for example, change the extension temporarily to `.zip`).

2. Delete the `iTunesMetadata.plist` file.

3. Zip up the remaining files into a new zip archive, and rename the new archive from `.zip` back to `.ipa`
(Important: the "Payload" folder must appear in the top level of zip archive)




## Additional information

The IPA build logic has been _corrected_ in Xamarin.iOS 9.2 so that it now properly respects the `IpaIncludeArtwork` element. Unfortunately this _fix_ has exposed other problems with the IDE project properties. In the case of Visual Studio, the "Project Properties -> iOS IPA Options -> Include Artwork in IPA" checkbox _broke_ so that it had no effect whatsoever. That "checkbox breakage" has now been restored to the XamarinVS 3.11 behavior by the fix for non-public Bug 36060, currently scheduled to be release in the upcoming Cycle 6 – Service Release 1.


See Bug 36407 (filed against Xamarin Studio, but explains the latest status for both Visual Studio and Xamarin Studio) for additional details.
Comment 1 Brendan Zagaeski (Xamarin Team, assistant) 2015-12-03 16:54:43 UTC
## Status update

The incorrect behavior of the "Project Properties -> iOS IPA Options -> Include Artwork in IPA" checkbox now has a candidate fix that is scheduled to be released in the upcoming Cycle 6 – Service Release 1 (which will tentatively be available in an early Alpha Channel version within the next couple of weeks).
Comment 3 Brendan Zagaeski (Xamarin Team, assistant) 2016-01-14 22:20:33 UTC
*** Bug 37645 has been marked as a duplicate of this bug. ***