Bug 36440 - UNC paths should be of the form \\server\share error when adding web service reference
Summary: UNC paths should be of the form \\server\share error when adding web service ...
Status: RESOLVED DUPLICATE of bug 36116
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General (show other bugs)
Version: 5.10 (C6SR3)
Hardware: PC Mac OS
: --- normal
Target Milestone: master
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-12-01 19:23 UTC by John Miller [MSFT]
Modified: 2015-12-01 20:29 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 36116

Description John Miller [MSFT] 2015-12-01 19:23:26 UTC
**Overview:**

   Adding a .NET 2.0 web service references adds incorrect relative file path links to the .csproj

**Steps to Reproduce:**

   1. Create a new iOS project
   2. Right-click on the project and Add -> Web Reference
   3. Change it to .NET 2.0 Web Service
   4. Add a web service URL to the top
   5. Click OK. 

   Note* The .disco and .wsdl file are red and the paths in the .csproj look something like 

<None Include="..\..\..\..\..\TempConvert.disco" />
<None Include="..\..\..\..\..\TempConvert.wsdl" />

Close the solution and re-open it to see the error dialog.

**Actual Results:**

   UNC paths should be of the form \\server\share

**Expected Results:**

   File paths should look similar to :

<None Include="Web References\Servicio\TempConvert.disco" />
<None Include="Web References\Servicio\TempConvert.wsdl" />

**Build Date & Platform:**

   === Xamarin Studio ===

Version 5.10 (build 871)
Installation UUID: e01c3049-a2d2-4e0a-aad8-afe6fb627c4d
Runtime:
	Mono 4.2.1 (explicit/6dd2d0d)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 402010102

=== Xamarin.Profiler ===

Version: 0.20.0.0
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Apple Developer Tools ===

Xcode 7.1 (9079)
Build 7B91b

=== Xamarin.iOS ===

Version: 9.2.1.51 (Business Edition)
Hash: 3c0ec35
Branch: master
Build date: 2015-11-12 13:05:39-0500

=== Xamarin.Android ===

Version: 6.0.0.34 (Business Edition)
Android SDK: /Users/johnmiller/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.4   (API level 19)
		5.0   (API level 21)
		5.1   (API level 22)
		6.0   (API level 23)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.0.1
SDK Build Tools Version: 23.0.1

Java SDK: /usr
java version "1.8.0_60"
Java(TM) SE Runtime Environment (build 1.8.0_60-b27)
Java HotSpot(TM) 64-Bit Server VM (build 25.60-b23, mixed mode)

=== Xamarin Android Player ===

Version: 0.6.5
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: 2.4.0.109 (Business Edition)

=== Build Information ===

Release ID: 510000871
Git revision: 4e9c5abb5ffdae12ba02ac49da83f8b2011dbb88
Build date: 2015-11-12 06:02:54-05
Xamarin addins: 55007ed0e56436f385d8e26394a45be563abc7e8
Build lane: monodevelop-lion-cycle6

=== Operating System ===

Mac OS X 10.10.5

**Additional Information:**

   https://forums.xamarin.com/discussion/55933/unc-paths-should-be-of-the-form-server-share
Comment 1 Brendan Zagaeski (Xamarin Team, assistant) 2015-12-01 19:27:11 UTC
At first glance this appears like it might be a duplicate of Bug 36116.
Comment 2 Matt Ward 2015-12-01 20:29:07 UTC
The cause of the strange paths added to the project file is bug #36116.

Xamarin Studio is adding the path to the files at the root directory due to the incorrect '/' added to the filename by Mono 4.2 so you get strange paths and the files show up in the root of the project in red.

Marking this as a duplicate.

*** This bug has been marked as a duplicate of bug 36116 ***