Bug 364 - Mysterious runtime crashes
Summary: Mysterious runtime crashes
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Runtime
Classification: Mono
Component: General (show other bugs)
Version: unspecified
Hardware: PC Linux
: Normal enhancement
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-08-22 17:29 UTC by Mark Probst
Modified: 2018-01-18 20:47 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Test case (689 bytes, text/plain)
2011-08-22 17:29 UTC, Mark Probst
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Mark Probst 2011-08-22 17:29:05 UTC
Created attachment 164 [details]
Test case

This crashes the runtime in various ways at least on Linux/AMD64 (it's ok if it throws InvalidOperationException).

When running on SGen it happens now and then that an object's vtable pointer appears to be overwritten.  In those cases, however, the value in memory is often correct at the point of crash, but the value that was read from memory is faulty.  The lower 32 bits of the read value are usually correct as well, though.

In other cases it asserts in mono_arch_find_jit_info() in exceptions-amd64.c because an LMF's previous_lmf field has the 2 bit set even though the soft debug code is never called.  Setting a watchpoint to catch an offending write to the mono_lmf TLS variable makes it not happen.

Sometimes it crashes by jumping to non-code.
Comment 1 Rodrigo Kumpera 2012-04-23 00:01:35 UTC
This test will fail because suspend/resume/abort are not synchronous in mono so you can't safely pair Suspend/Resume and expect it to work.
Comment 2 Ludovic Henry 2018-01-18 20:47:54 UTC
I cannot reproduce with Mono 5.11.0.276 (master/117468d740a)