Bug 36315 - UDPClient should use IPAddress.Family instead of Any
Summary: UDPClient should use IPAddress.Family instead of Any
Status: RESOLVED DUPLICATE of bug 6057
Alias: None
Product: Class Libraries
Classification: Mono
Component: System (show other bugs)
Version: 4.2.0 (C6)
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: marcos.henrich
URL:
Depends on:
Blocks:
 
Reported: 2015-11-27 16:50 UTC by John Miller [MSFT]
Modified: 2015-12-01 20:12 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 6057

Description John Miller [MSFT] 2015-11-27 16:50:27 UTC
**Overview:**
https://github.com/mono/mono/blob/b7a308f660de8174b64697a422abfc7315d07b8c/mcs/class/System/System.Net.Sockets/UdpClient.cs#L301

This should use ‘family’, not IPAddress.Any.
Comment 4 Jan Vilhuber 2015-11-30 15:26:06 UTC
My problem description is a little too vague. For the correct description, see https://bugzilla.xamarin.com/show_bug.cgi?id=6057, which is exactly the problem I'm hitting, and which has the proper fix in the description as well.
Comment 5 Rodrigo Kumpera 2015-12-01 17:26:51 UTC
Hey Marcos,

This one looks like a dupe of another one you worked earlier.
Comment 6 marcos.henrich 2015-12-01 20:12:43 UTC
This should be fixed by PR 2274
https://github.com/mono/mono/pull/2274

*** This bug has been marked as a duplicate of bug 6057 ***