Bug 36257 - Runtime crashes when debugging .ppdb(when requesting arguments)
Summary: Runtime crashes when debugging .ppdb(when requesting arguments)
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: Debugger (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Zoltan Varga
URL:
: 41233 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-11-25 13:57 UTC by David Karlaš
Modified: 2016-05-21 12:02 UTC (History)
4 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description David Karlaš 2015-11-25 13:57:10 UTC
Steps to reproduce:
1. git clone https://github.com/DavidKarlas/sdb.git
2. cd sdb
3. git checkout 1354fe64fc3f24c5d88cc4534a780ac4fa009624
4. git submodule update --init --recursive
5. make
6. OPTIONAL(I commited compiled Program.exe/pdb): mono ~/GIT/roslyn/Binaries/Debug/csc.exe Program.cs  /noconfig /debug:portable
7. In second Console window run "mono --debugger-agent=transport=dt_socket,address=127.0.0.1:12345,server=y Program.exe"
8. bin/sdb -f Commands.txt

Mono git sha: 828d7d782b603f3eccf986637ec1fd9e83513482
Roslyn git sha: 851f060f3f18cc1585a0ef1a3caa5e23bb8f69eb

Crash error:
* Assertion at metadata.c:1025, condition `idx < t->rows' not met

Stacktrace:


Native stacktrace:

	0   mono                                0x001ab336 mono_handle_native_sigsegv + 342
	1   mono                                0x00216d61 sigabrt_signal_handler + 145
	2   libsystem_platform.dylib            0x92ea979b _sigtramp + 43
	3   ???                                 0xffffffff 0x0 + 4294967295
	4   mono                                0x00c2230b abort + 27
	5   mono                                0x0036f951 monoeg_log_default_handler + 129
	6   mono                                0x0036fa4b monoeg_assertion_message + 107
	7   mono                                0x0027c760 mono_metadata_decode_row + 224
	8   mono                                0x0023ec73 mono_ppdb_lookup_locals + 211
	9   mono                                0x0029b79c mono_debug_lookup_locals + 140
	10  mono                                0x001d9536 method_commands + 2246
	11  mono                                0x001d203b debugger_thread + 4235
	12  mono                                0x003681a2 inner_start_thread + 274
	13  libsystem_pthread.dylib             0x9807e794 _pthread_body + 138
	14  libsystem_pthread.dylib             0x9807e70a _pthread_body + 0
	15  libsystem_pthread.dylib             0x9807bfa6 thread_start + 34
Comment 1 Zoltan Varga 2015-11-28 14:56:19 UTC
Fixed in mono master/4.3.1.
Comment 2 Alexander Köplinger [MSFT] 2016-05-21 12:02:36 UTC
*** Bug 41233 has been marked as a duplicate of this bug. ***

Notice (2018-05-21): bugzilla.xamarin.com will be switching to read-only mode on Thursday, 2018-05-25 22:00 UTC.

Please join us on Visual Studio Developer Community and GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs and copy them to the new locations as needed for follow-up. The See Also field on each Bugzilla bug will be updated with a link to its new location when applicable.

After Bugzilla is read-only, if you have new information to add for a bug that does not yet have a matching issue on Developer Community or GitHub, you can create a follow-up issue in the new location. Copy and paste the title and description from this bug, and then add your new details. You can get a pre-formatted version of the title and description here:

In special cases you might also want the comments:

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Note You need to log in before you can comment on or make changes to this bug.