Bug 36235 - Strange mdb filenames when using Visual Studio (Android/iOS)
Summary: Strange mdb filenames when using Visual Studio (Android/iOS)
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General (show other bugs)
Version: 4.0.0 (C6)
Hardware: PC Windows
: Normal normal
Target Milestone: 4.1.0 (C7)
Assignee: dean.ellis
URL:
Depends on:
Blocks:
 
Reported: 2015-11-25 01:38 UTC by Virgile Bello
Modified: 2016-05-20 16:33 UTC (History)
7 users (show)

Tags: BZSRC6S1, _XVSC6SR2
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Virgile Bello 2015-11-25 01:38:44 UTC
Since C6, we have mdb files like `SiliconStudio.Core.IO.dllSiliconStudio.Core.IO.dll.mdb` instead of `SiliconStudio.Core.IO.dll.mdb`.

I think this is due to the Xamarin.Android.Common.targets using %(TargetPath)%(Filename)%(Extension); Targetpath already contains Filename and Extension, so everything is duplicated.
Comment 1 Joaquin Jares 2015-11-26 08:50:43 UTC
Assigned to me for review/fixing.
Comment 2 Joaquin Jares 2015-11-26 12:31:22 UTC
Agreed on fix with dean, assigning to him for now (may revert back to me if his fix isn't viable).
Comment 3 dean.ellis 2015-11-30 14:19:56 UTC
Fixed in monodroid/master/853c2a8d