Bug 36230 - [System.Diagnostics] System.InvalidCastException: Specified cast is not valid.
Summary: [System.Diagnostics] System.InvalidCastException: Specified cast is not valid.
Status: RESOLVED NORESPONSE
Alias: None
Product: Class Libraries
Classification: Mono
Component: System (show other bugs)
Version: 4.2.0 (C6)
Hardware: PC Linux
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-11-24 20:05 UTC by André
Modified: 2018-03-13 11:07 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Stack trace (3.69 KB, text/plain)
2015-11-24 20:05 UTC, André
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description André 2015-11-24 20:05:02 UTC
Created attachment 13984 [details]
Stack trace

Mono 4.2.X throws an exception during Monodevelop startup.
This exception is not thrown with Mono 4.0.4.1.
See also: https://bbs.archlinux.org/viewtopic.php?id=196097
Comment 1 Marek Safar 2015-11-26 11:06:44 UTC
I cannot reproduce the issue. Do you have customized Monodevelop.exe.config file? If so please attach it.
Comment 2 Su Liu 2015-12-22 16:35:05 UTC
I am able to repro:

System.InvalidCastException: Specified cast is not valid.
  at System.Diagnostics.DiagnosticsConfiguration.GetConfigSection () <0x21e9440 + 0x00029> in <filename unknown>:0 
  at System.Diagnostics.DiagnosticsConfiguration.Initialize () <0x21e9380 + 0x0005f> in <filename unknown>:0 
  at System.Diagnostics.DiagnosticsConfiguration.get_IndentSize () <0x21e9310 + 0x0000b> in <filename unknown>:0 
  at System.Diagnostics.TraceInternal.InitializeSettings () <0x21e91b0 + 0x00093> in <filename unknown>:0 
  at System.Diagnostics.TraceInternal.get_Listeners () <0x21e9000 + 0x00017> in <filename unknown>:0 
  at System.Diagnostics.Trace.get_Listeners () <0x21d8fa8 + 0x0003b> in <filename unknown>:0 
...

[ERROR] FATAL UNHANDLED EXCEPTION: System.InvalidCastException: Specified cast is not valid.
  at System.Diagnostics.DiagnosticsConfiguration.GetConfigSection () <0x21e9440 + 0x00029> in <filename unknown>:0 
  at System.Diagnostics.DiagnosticsConfiguration.Initialize () <0x21e9380 + 0x0005f> in <filename unknown>:0 
  at System.Diagnostics.DiagnosticsConfiguration.get_IndentSize () <0x21e9310 + 0x0000b> in <filename unknown>:0 
  at System.Diagnostics.TraceInternal.InitializeSettings () <0x21e91b0 + 0x00093> in <filename unknown>:0 
  at System.Diagnostics.TraceInternal.get_Listeners () <0x21e9000 + 0x00017> in <filename unknown>:0 
  at System.Diagnostics.Trace.get_Listeners () <0x21d8fa8 + 0x0003b> in <filename unknown>:0 
...
Comment 3 Marek Safar 2018-03-13 11:07:26 UTC
We have not received the requested information. If you are still experiencing this issue please provide all the requested information and reopen the bug report.

Thank you!