Bug 36223 - Could not find file "/usr/bin/mono-sgen.config".
Summary: Could not find file "/usr/bin/mono-sgen.config".
Status: RESOLVED NORESPONSE
Alias: None
Product: Runtime
Classification: Mono
Component: Debugger (show other bugs)
Version: 4.2.0 (C6)
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2015-11-24 16:25 UTC by Roman
Modified: 2017-10-11 19:07 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Roman 2015-11-24 16:25:16 UTC
After updating mono-runtime I get error in project which worked before without exception.
At first: In build process some 100 warnings appear.
At second: In debug my app have even not started. I saw exception Could not find file "/usr/bin/mono-sgen.config".
I open mc, really file "/usr/bin/mono-sgen.config" is missing!
Why?
How you frazzle out me by you bugs!! When will you begin testing your updating.
I have had mono version 3.2 and monodevelop version 5.9 and all worked excellent.
And now I have to remove all mono, remove your repository in order to install monodevelop 4 version. But I want monodevelop version 5.9! How can I install it again? Please help me!
Comment 1 Rodrigo Kumpera 2015-11-27 18:47:26 UTC
Hi Roman,

Can you provide us with more details on your setup? Maybe a test project that shows this behavior?
Comment 2 Roman 2015-11-28 04:23:09 UTC
I have project on monogame. Before updating of mono/monodevelop I had 40 warning in build proccess. After updating I got already 118 warning. Moreover I just run debug project and it does not start use to problem which is discribed in begin topic. What a details do you need more?
Comment 3 Rodrigo Kumpera 2015-11-28 11:11:25 UTC
WE need enough details on what you're doing so we can reproduce the behavior ourselves in order to understand what's going wrong for you.
Comment 4 Roman 2015-12-02 12:00:36 UTC
Nothing! I have just updated mono and monodevelop using update manager which time after time offers me to update some packages.
It is guilty this repository "deb http://download.mono-project.com/repo/debian wheezy main"
Comment 5 Roman 2015-12-25 00:04:34 UTC
I know root of problem and you must know why this happens.
So, my application use database MySQL. Connection string is written in app.config.
But I don't understand and you have to understand why mono search connection string in not myApp.exe.config and search it in /usr/bin/mono-sgen.config!!!
I use such code:

using System.Configuration;
...

string connectionString = ConfigurationManager.ConnectionStrings["InetConnection"].ConnectionString;
Comment 6 Rodrigo Kumpera 2017-10-11 17:15:52 UTC
We have not received the requested information. If you are still experiencing this issue please provide all the requested information and reopen the bug report.

Thank you!
Comment 7 Roman 2017-10-11 19:07:07 UTC
Rodrigo, you can close this report. After 5 version all works good