Bug 36174 - Android Search Bar vertical text alignment in Forms 2.0
Summary: Android Search Bar vertical text alignment in Forms 2.0
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Android (show other bugs)
Version: 2.0.0
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: E.Z. Hart [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2015-11-23 16:53 UTC by jmeyer
Modified: 2016-02-05 07:34 UTC (History)
6 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments
Two projects that demonstrate the alignment difference between SearchBar in Forms 1.* and Forms 2.0, plus related screen captures (73 bytes, text/plain)
2015-11-23 16:57 UTC, jmeyer
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description jmeyer 2015-11-23 16:53:12 UTC
Text that appears in the SearchBar component is no longer center-justified in Forms 2.0 on Android devices. Both "Placeholder" and "Text" are affected. See attached projects & screen captures demonstrating the issue

Reproduced issue on:
Galaxy S5 Mini running 4.4.2
VS Emulator 4.7" running 5.1.1
Comment 1 jmeyer 2015-11-23 16:57:51 UTC
Created attachment 13943 [details]
Two projects that demonstrate the alignment difference between SearchBar in Forms 1.* and Forms 2.0, plus related screen captures

File hosted on dropbox to support size constraints
Comment 2 João Serra 2015-11-25 14:09:38 UTC
Also happening on Galaxy s4. It looks like its top aligned.
Comment 3 Jason Smith [MSFT] 2015-12-14 23:55:28 UTC
Should be fixed in 2.0.2-pre1
Comment 4 Jason Smith [MSFT] 2015-12-14 23:55:43 UTC
Forgot to close
Comment 5 Rui Marinho 2016-01-20 12:23:10 UTC
Should be fixed in 2.1.0-pre1
Comment 6 Parmendra Kumar 2016-02-05 07:34:56 UTC
I have checked this issue with Xamarin.Forms 2.1.0-pre3 and now its working fine.

hence closing this issue.