Bug 36162 - Visual Studio hangs when loading solution
Summary: Visual Studio hangs when loading solution
Status: RESOLVED DUPLICATE of bug 36185
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General (show other bugs)
Version: 4.0.0 (C6)
Hardware: Macintosh Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-11-23 14:23 UTC by Alexandre Pepin
Modified: 2015-11-24 20:16 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Call stack (16.50 KB, text/plain)
2015-11-24 09:39 UTC, Alexandre Pepin
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 36185

Description Alexandre Pepin 2015-11-23 14:23:46 UTC
We have many projects (more than 100) in our solution and since Xamarin 4, Visual Studio hangs every time when loading the solution. We need to delete .suo file of the solution to make it work
Comment 1 Brendan Zagaeski (Xamarin Team, assistant) 2015-11-23 20:06:02 UTC
I am setting this bug to be "NEEDINFO" while it is awaiting additional information to determine whether it can be marked as a duplicate of Bug 36185.

The new information I'll request is described in Bug 36185, Comment 1. In particular, please attach back the call stack from the hung / frozen instance of Visual Studio by completing the following steps (anyone who comes across this bug report is welcome to attach back their own call stack).

> 1. Start a second instance (a "new window") of Visual Studio.
> 
> 2. Close any open solutions in the new instance of VS.
> 
> 3. Select "Debug -> Attach to Process".
> 
> 4. Select the original hung instance of `devenv.exe` from the list of
> "Available Processes".
> 
> 5. Select "Debug -> Break All".
> 
> 6. Make sure you have the "Debug Location" toolbar is enabled.
> 
> 7. From the "Thread" drop-down menu in the "Debug Location" toolbar, select the
> "Main Thread".
> 
> 8. Open "Debug -> Windows -> Call Stack". If the Call Stack shows just
> "[External Code]", then right-click "[External Code]" and select "Show External
> Code" from the context menu before copying the information.

Once you see the full call stack, select all the lines, copy and paste them into a text file, and attach back the text file.


Thanks in advance!
Brendan
Xamarin Customer Support
Comment 2 Brendan Zagaeski (Xamarin Team, assistant) 2015-11-24 01:58:58 UTC
Small wording correction for step 8:

> 8. Open "Debug -> Windows -> Call Stack". If the Call Stack contains _any lines_
> that say "[External Code]", right-click "[External Code]" and select "Show
> External Code" from the context menu before copying the information.
Comment 3 Alexandre Pepin 2015-11-24 09:39:42 UTC
Created attachment 13971 [details]
Call stack
Comment 4 Brendan Zagaeski (Xamarin Team, assistant) 2015-11-24 20:16:28 UTC
Perfect. Thanks! That call stack does indeed match Bug 36185, so I'll mark this as a duplicate to help keep the bug list tidy.

*** This bug has been marked as a duplicate of bug 36185 ***