Bug 36117 - [XVS.iOS 4.0] Certain distribution provisioning profiles do not appear in the iOS project settings
Summary: [XVS.iOS 4.0] Certain distribution provisioning profiles do not appear in the...
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS (show other bugs)
Version: 4.0.0 (C6)
Hardware: PC Windows
: Highest normal
Target Milestone: 4.0.1 (C6SR1)
Assignee: Bugzilla
URL:
: 35615 36193 (view as bug list)
Depends on: 35615
Blocks: 38585
  Show dependency tree
 
Reported: 2015-11-20 17:52 UTC by Brendan Zagaeski (Xamarin Support)
Modified: 2016-02-26 22:11 UTC (History)
12 users (show)

See Also:
Tags: _XVS1215
Is this bug a regression?: ---
Last known good build:


Attachments
Detailed version info (2.76 KB, application/zip)
2015-11-20 17:52 UTC, Brendan Zagaeski (Xamarin Support)
Details

Description Brendan Zagaeski (Xamarin Support) 2015-11-20 17:52:37 UTC
Created attachment 13925 [details]
Detailed version info

[XVS.iOS 4.0] Certain distribution provisioning profiles do not appear in the iOS project settings


(This is an intentional duplicate of non-public Bug 35615 for public tracking and to document a possible temporary workaround.)


## Possible temporary workaround

This problem is limited to _browsing_ the provisioning profiles. If you set the desired "CodesignProvision" and "CodesignKey" using Xamarin Studio on Mac, the values will be preserved in the project file, and the app will be signed correctly when _building_ in Visual Studio on Windows. Similarly, if you set the desired provisioning profile on Mac, save the project, and then open the `.csproj` file in a text editor, you can find the `<CodesignProvision>` and `<CodesignKey>` elements, and then copy them into the corresponding location in the `.csproj` file on Windows. (Be sure to place these properties under the matching `<PropertyGroup Condition=" '$(Configuration)|$(Platform)'` section of the file that corresponds to the configuration you wish to use`.)




## Regression status: regression in XamarinVS 4.0

BAD:  XamarinVS 4.0.0.1689  (f860fe4) + Xamarin.iOS 9.2.1.51 (3c0ec35)
GOOD: XamarinVS 3.11.1594.0 (a06d6d5) + Xamarin.iOS 9.1.0.27 (1f068b4)




## Steps I followed to reproduce

1. Create a new iOS application or open an existing iOS application.

2. Set the configuration to "Release|iPhone".

3. Open the project properties, and navigate to "iOS Bundle Signing".

4. Ensure the "Identity" is set to a valid Distribution identity (or "Distribution (Automatic)").

5. Click the "Provisioning profile" drop-down.




## Actual Results

I have 2 non-expired distribution profiles present in "$HOME/Library/MobileDevice", but _only_ the "AdHoc Distribution, Wildcard" provisioning profile is displayed in the "Provisioning profile" drop-down at step 5.

1.
>	<key>AppIDName</key>
>	<string>Xcode iOS Wildcard App ID</string>

>	<key>Name</key>
>	<string>AppStore distribution wildcard</string>


2. 
>	<key>AppIDName</key>
>	<string>Xcode iOS Wildcard App ID</string>

>	<key>Name</key>
>	<string>AdHoc Distribution, Wildcard</string>



## Expected Results

In XamarinVS 3.11, the "AppStore distribution wildcard" provisioning profile appears as expected in the iOS project properties.
Comment 3 Brendan Zagaeski (Xamarin Support) 2015-11-20 18:06:47 UTC
A candidate patch has been committed to fix this issue. It is currently targeted for inclusion in an Alpha Channel Service Release during the week of November 23.

I will post any relevant additional updates on this bug report as they become available.
Comment 4 Brendan Zagaeski (Xamarin Support) 2015-11-24 02:15:57 UTC
*** Bug 36193 has been marked as a duplicate of this bug. ***
Comment 5 Brendan Zagaeski (Xamarin Support) 2015-11-24 17:35:29 UTC
The patch for this issue has not yet been merged into the initial version of "Cycle 6 – Service Release 0" that is planned for release to the Alpha Channel this week.

It might be included in a later build of Service Release 0, but for the moment the most direct way to  address the problem is to continue using the "temporary workaround" from comment 0.

I will continue to post any further updates on this bug report as they become available.
Comment 8 Brendan Zagaeski (Xamarin Support) 2015-12-08 20:17:01 UTC
I will tentatively mark this as "reopened" based on my preliminary testing with development builds that included the candidate patch for this issue. In those preliminary tests, my distribution profiles did not appear as expected.

I will test again with the Cycle 6 – Service Release 1 Alpha builds and update accordingly.
Comment 9 Brendan Zagaeski (Xamarin Support) 2015-12-10 20:09:41 UTC
## Verification status: not yet fixed in Cycle 6 – Service Release 1 Alpha 1

BAD: XamarinVS 4.0.1.32 (944b6bd) + Xamarin.iOS 9.2.2.29 (97af501)




## Results

Now both of my distribution provisioning profiles [1, 2] are absent from the menu. Maybe this is an interesting clue?

[1] "AppStore distribution wildcard"
[2] "AdHoc Distribution, Wildcard"
Comment 11 Brendan Zagaeski (Xamarin Support) 2015-12-10 21:32:43 UTC
*** Bug 35615 has been marked as a duplicate of this bug. ***
Comment 14 xamarin-release-manager 2015-12-17 18:27:27 UTC
Fixed in version 99.0.0.1127 (xcode7.1)

Author: joj
Commit: b3abd4d93a494fe278f1b71d313bf2c5c58dff53 (xamarin/XamarinVS)
Comment 16 Yuri 2015-12-18 22:17:26 UTC
I have xcode7.2. Does it work there?
Comment 17 Brendan Zagaeski (Xamarin Support) 2015-12-19 21:45:57 UTC
## Status clarification for any users CC'd on the bug

The candidate fix for this issue is included in the latest Alpha version of "Cycle 6 - Service Release 1" [1].

[1] https://releases.xamarin.com/alpha-preview-2-cycle-6-service-release-1/



### Side note: Xcode version should not affect this bug

The Mac build host's Xcode version should not affect this bug. To clarify about the automated text in Comment 14, "(xcode7.1)" is just a branch name for the XamarinVS source code where a candidate fix for this bug was initially committed. That fix has now been merged into "Service Release 1". The fix is present in XamarinVS itself, so the Mac build host's Xcode version is not too important.




## Verification status: fixed with the latest Alpha versions

GOOD: XamarinVS 4.0.1.60 (7082690) + Xamarin.iOS 9.4.1.12 (78c6cd3)


I was able to find both of my distribution profiles (as well as all of my development profiles) using the latest Alpha versions. I was also able to select and save either of the profiles correctly, and I was build and sign successfully.
Comment 20 Brendan Zagaeski (Xamarin Support) 2016-02-19 19:54:27 UTC
## Status update for any users watching this bug

There is at least one additional case where provisioning profiles are not displayed as expected in the Visual Studio project properties in the current Stable version. That remaining issue is now being tracked in its own bug report:

Bug 38585 - Enterprise "In House" provisioning profiles do not appear in the drop-down menu in the iOS project settings editor
Comment 21 xamarin-release-manager 2016-02-26 22:11:12 UTC
Fixed in version 4.0.1.127 (cycle6)

Author: joj
Commit: f2e586517abe2c0558a04a729d45f7f08336aa91 (xamarin/XamarinVS)

Note You need to log in before you can comment on or make changes to this bug.