Bug 36017 - Android debugger disconnecting
Summary: Android debugger disconnecting
Status: RESOLVED DUPLICATE of bug 35798
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger (show other bugs)
Version: 5.10 (C6SR3)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: master
Assignee: David Karlaš
URL:
Depends on:
Blocks:
 
Reported: 2015-11-18 13:07 UTC by Dario
Modified: 2015-11-18 23:47 UTC (History)
2 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Dario 2015-11-18 13:07:55 UTC
Description of Problem:
Android debugger disconnects nearly every time after recent update

Steps to reproduce the problem:
1. Set breakpoint
2. Launch app
3. Hit breakpoint
4. Breakpoint is hit
5. Debugger disconnects after trying to do anything


Actual Results:
Debugger disconnects

Expected Results:
Debugger stays connected

How often does this happen? 
100% of the time

Additional Information:
Sometimes, the debugger fails to connect at all
Comment 1 David Karlaš 2015-11-18 13:14:40 UTC
Hi,

can you try this?
-Close XamarinStudio.
-Instal http://download.xamarin.com/studio/Windows/XamarinStudio-5.9.6.23-0.msi
-Start XamarinStudio and try to reproduce.

If you can still reproduce problem can you do same with http://download.xamarin.com/XamarinforVisualStudio/Windows/Xamarin.VisualStudio_3.11.1594.msi

I would like to determine which side is problem here XS or Android SDK.

Can you also attach Ide.log? https://kb.xamarin.com/customer/portal/articles/1675684-where-can-i-find-my-version-information-and-logs-

Thank you,
David
Comment 2 Dario 2015-11-18 13:23:27 UTC
I am on OS X :)
Comment 3 David Karlaš 2015-11-18 13:25:12 UTC
Sorry about that,
I mixed with another bug...
XS: http://download.xamarin.com/studio/Mac/XamarinStudio-5.9.8.0-0.dmg
Android: http://download.xamarin.com/MonoforAndroid/Mac/mono-android-5.1.9-0.pkg
Comment 4 Dario 2015-11-18 14:02:55 UTC
Same problem. In fact, now I'm not even getting a "debugger disconnected" message box. The app just dies and the debugger disconnects
Comment 5 David Karlaš 2015-11-18 14:10:10 UTC
1) What Android simulator/emulator are you using?

2) Can you please attach log files?
https://kb.xamarin.com/customer/portal/articles/1675684-where-can-i-find-my-version-information-and-logs-

3) Can you try with device or maybe Google Android Emulator?
Comment 6 Dario 2015-11-18 17:23:09 UTC
Seems like it might be related to my device. I seem to most consistently be able to reproduce the problem when I'm connected to my Nexus 6P which is running Marshmallow. I'll try and get you some logs. Which logs specifically were you looking for?
Comment 7 Peter Collins 2015-11-18 23:47:17 UTC
@Dario adb logcat would be useful for this failure scenario.

Out of curiosity, are you using the shared runtime for your debug builds? Does your apk include support for arm64-v8a? We're looking at an issue that's possibly related in Bug #35798, but from what I've seen it's only reproducible when the app _only_ supports armeabi-v7a.

I'll mark this as a duplicate of that issue, please provide any additional information on Bug #35798.

*** This bug has been marked as a duplicate of bug 35798 ***

Note You need to log in before you can comment on or make changes to this bug.