Bug 36003 - Invalid DateTime format for Finnish and DateTime parser not supporting same separator for date and time
Summary: Invalid DateTime format for Finnish and DateTime parser not supporting same s...
Status: VERIFIED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: mscorlib (show other bugs)
Version: master
Hardware: All Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2015-11-18 09:58 UTC by Dominique NORMAND
Modified: 2015-12-15 06:53 UTC (History)
10 users (show)

Tags: BZCU
Is this bug a regression?: ---
Last known good build:


Attachments
Sample project to reproduce the issue (3.64 KB, application/octet-stream)
2015-11-18 09:58 UTC, Dominique NORMAND
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Dominique NORMAND 2015-11-18 09:58:38 UTC
Created attachment 13865 [details]
Sample project to reproduce the issue

MONO date time format for Finnish (fi-FI) is incorrect. The time separator is ':' instead of '.' . This causes Mono DateFormat to not be in sync with the native one (iOS).
Once we change the time separator to be '.' ( So that it's in Sync with iOS) we get parsing exceptions because MONO's DateTime parser doesn't support having the same character for date separator and time separator.
Comment 1 Marek Safar 2015-11-19 07:41:38 UTC
I am updating cultures data to see if that fixes the issue
Comment 2 Marek Safar 2015-11-19 08:58:06 UTC
Fixed the time separator value in Mono master
Comment 3 Marek Safar 2015-11-20 18:21:12 UTC
Fixed in mono master, proposed for SR1
Comment 4 Arpit Jha 2015-11-24 03:37:05 UTC
As per comment 2,I have checked  this issue with latest mono master  MonoFramework-MDK-4.3.0.2163.macos10.xamarin.universal_f82f4e84b1332d94e52be8258f37f6d623c0a2c3 having MD5 f1017f92732e63852b57c4dc0b495ef5 and with the help of  attached project in bug description.

Observed that issue still exist as mentioned in bug description, Getting System.DateTimeParse.Parse exception.

App output: https://gist.github.com/Arpit360/e57a7ba956085b944116
Screencast: http://www.screencast.com/t/ajF7d6xF

Full Environment Info: https://gist.github.com/Arpit360/2217d412e3adf260e60d

For now, I am Reopening this issue.

Please let me know If I am missing anything.
Comment 5 Marek Safar 2015-11-25 09:29:40 UTC
please read my comments first before reopening the bug report.

The issue was fixed in Mono master and proposed for SR1. The attached repro uses XI therefore you'd need Mono master based XI for your repro to work. Master XI is based on Mono 4.3.1 which does not included the fix.
Comment 7 Marek Safar 2015-11-26 04:02:40 UTC
As I wrote earlier there is no XI which includes the fix yet
Comment 8 Arpit Jha 2015-12-15 06:53:25 UTC
I have checked this issue with latest master mono MonoFramework-MDK-4.3.2.34.macos10.xamarin.universal_f81f8763c1ae3c544ecf9a8404e1fe5ea1fb489e + monotouch-9.4.1.1  and its working fine.

Now able to build and deploy attached project without any exception.

Screencast: http://www.screencast.com/t/HgXFLwuL4l6

Full Environment Info:
https://gist.github.com/Arpit360/7894b76414dafa05a21b

Hence closing this issue.