Bug 35980 - CSharpCodeCompiler.CompileXYZ false positive error when warning is 'X hides inherited member'
Summary: CSharpCodeCompiler.CompileXYZ false positive error when warning is 'X hides i...
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: System (show other bugs)
Version: 4.0.0
Hardware: PC Linux
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-11-18 05:07 UTC by Kalyanov.Dmitry
Modified: 2015-11-24 09:28 UTC (History)
2 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Code to reproduce the bug (1.43 KB, text/x-csharp)
2015-11-18 05:07 UTC, Kalyanov.Dmitry
Details

Description Kalyanov.Dmitry 2015-11-18 05:07:57 UTC
Created attachment 13857 [details]
Code to reproduce the bug

The following code, when compiled via CSharpCodeCompiler, produces false error:

public class A
{
    public virtual void F() {}
}
    
public class B: A
{
    public virtual void F() {}
}

This code generates 1 warning and 1 error:
  
/tmp/fa35333/69a87839.0.cs(22,29) : warning CS0114: `NS.B.F()' hides inherited member `NS.A.F()'. To make the current member override that implementation, add the override keyword. Otherwise add the new keyword

(0,0) : error : /tmp/fa35333/69a87839.0.cs(16,29): (Location of the symbol related to previous warning)

Mono.CSharp.CSharpCodeCompiler.CreateErrorFromString incorrectly treats the additional line "(Location of the symbol related to previous warning)" in stderr output of mcs as an error since it doesn't match the ErrorRegexPattern regex.
Comment 1 Alexander Köplinger [MSFT] 2015-11-24 09:28:17 UTC
Fixed in master via https://github.com/mono/mono/pull/2248.

Notice (2018-05-21): bugzilla.xamarin.com will be switching to read-only mode on Thursday, 2018-05-25 22:00 UTC.

Please join us on Visual Studio Developer Community and GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs and copy them to the new locations as needed for follow-up. The See Also field on each Bugzilla bug will be updated with a link to its new location when applicable.

After Bugzilla is read-only, if you have new information to add for a bug that does not yet have a matching issue on Developer Community or GitHub, you can create a follow-up issue in the new location. Copy and paste the title and description from this bug, and then add your new details. You can get a pre-formatted version of the title and description here:

In special cases you might also want the comments:

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Note You need to log in before you can comment on or make changes to this bug.