Bug 35977 - I cant input Japanese charactor
Summary: I cant input Japanese charactor
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor (show other bugs)
Version: 5.10 (C6SR3)
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: C6SR1
Assignee: Cody Russell
URL:
: 35968 36325 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-11-18 04:40 UTC by Yoshito Tabuchi
Modified: 2016-01-11 11:04 UTC (History)
7 users (show)

See Also:
Tags: gtk
Is this bug a regression?: ---
Last known good build:


Attachments
I tried input Japanes in Sublime Text 1st, then tried in Xamarin Studio. (494.71 KB, image/gif)
2015-11-18 04:40 UTC, Yoshito Tabuchi
Details

Description Yoshito Tabuchi 2015-11-18 04:40:33 UTC
Created attachment 13855 [details]
I tried input Japanes in Sublime Text 1st, then tried in Xamarin Studio.

Description of Problem:
I cant input any Japanese characters. 
** Japanese IME has 2 modes, these are Japanese mode and English mode. Xamarin Studio 4.x could handled 2 modes properly. But Xamarin Studio 5.10 can't handling IME mode. 

Steps to reproduce the problem:
1. Prepare Mac OS with Japanese language
2. Launch Xamarin Studio
3. Try input any Japanese character 


Actual Results:
I cant input Japanese characters.

Expected Results:
I can input Japanese

How often does this happen? 
Any time

Additional Information:
Mac OS X Yosemite 10.10.5

Xamarin Studio
Version 5.10 (build 871)
Installation UUID: fb3c6857-c774-443e-8eee-d2d33f9292f4
Runtime:
	Mono 4.2.1 (explicit/6dd2d0d)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 402010102

Xamarin.Profiler
Not Installed

Apple Developer Tools
Xcode 7.0 (8227)
Build 7A220

Xamarin.iOS
Version: 9.2.1.51 (Trial Edition)
Hash: 3c0ec35
Branch: master
Build date: 2015-11-12 13:05:39-0500

Xamarin.Android
Version: 6.0.0.34 (Trial Edition)
Android SDK: /Applications/Android/sdk
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.4   (API level 19)
		5.0   (API level 21)
		5.1   (API level 22)
		6.0   (API level 23)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.0.1
SDK Build Tools Version: 23.0.1

Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

Xamarin Android Player
Version: 0.6.5
Location: /Applications/Xamarin Android Player.app

Xamarin.Mac
Version: 2.4.0.109 (Trial Edition)

Build Information
Release ID: 510000871
Git revision: 4e9c5abb5ffdae12ba02ac49da83f8b2011dbb88
Build date: 2015-11-12 06:02:54-05
Xamarin addins: 55007ed0e56436f385d8e26394a45be563abc7e8
Build lane: monodevelop-lion-cycle6

Operating System
Mac OS X 10.10.5
Darwin MBA-Xamarin.local 14.5.0 Darwin Kernel Version 14.5.0
    Wed Jul 29 02:26:53 PDT 2015
    root:xnu-2782.40.9~1/RELEASE_X86_64 x86_64
Comment 1 Lluis Sanchez 2015-11-19 10:10:47 UTC
*** Bug 35968 has been marked as a duplicate of this bug. ***
Comment 2 islandof 2015-11-19 20:18:01 UTC
same to me ,after update this version ,I can't input any Chinese  characters
Comment 3 Rajneesh Kumar 2015-11-20 07:06:58 UTC
I have checked this issue and able to reproduce this. To reproduce this issue I have followed the steps and instruction provided in bug description. After setting OS X language to Japanese language  I observed that user is not able to input Japanese characters.

Screencast: http://www.screencast.com/t/IhayJEE8

Ide Logs: https://gist.github.com/Rajneesh360Logica/e1d67b10e5839fb55650

Environemnt Info:

=== Xamarin Studio ===

Version 5.10 (build 872)
Installation UUID: 0b7eaebc-a0ed-4b58-81df-91e378cad28c
Runtime:
	Mono 4.2.1 (explicit/6dd2d0d)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 402010102

=== Xamarin.Profiler ===

Version: 0.0.0.0
Location: /Applications/XamarinProfiler.Mac.app/Contents/MacOS/XamarinProfiler.Mac

=== Apple Developer Tools ===

Xcode 7.1 (9079)
Build 7B91b

=== Xamarin.Mac ===

Version: 2.4.0.109 (Trial Edition)

=== Xamarin.iOS ===

Version: 9.2.1.48 (Trial Edition)
Hash: 62c70ea
Branch: master
Build date: 2015-11-09 19:01:07-0500

=== Xamarin.Android ===

Version: 6.0.0.33 (Trial Edition)
Android SDK: /Android SDK/android-sdk-macosx
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
		6.0    (API level 23)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.0.1
SDK Build Tools Version: 23.0.1

Java SDK: /usr
java version "1.7.0_25"
Java(TM) SE Runtime Environment (build 1.7.0_25-b15)
Java HotSpot(TM) 64-Bit Server VM (build 23.25-b01, mixed mode)

=== Xamarin Android Player ===

Version: 0.6.1
Location: /Applications/Xamarin Android Player.app

=== Build Information ===

Release ID: 510000872
Git revision: 18af1ba26343fb73877cc8081a808e3100fa00e5
Build date: 2015-11-18 05:58:59-05
Xamarin addins: 7d8e6d12fd79bb0a3ebe4f6f0d0ad7c984c2ad88
Build lane: monodevelop-lion-cycle6

=== Operating System ===

Mac OS X 10.11.0
Darwin Admin-Macs-Mac-mini.local 15.0.0 Darwin Kernel Version 15.0.0
    Wed Aug 26 16:57:32 PDT 2015
    root:xnu-3247.1.106~1/RELEASE_X86_64 x86_64
Comment 4 Cody Russell 2015-12-09 18:06:57 UTC
Fix has been committed to github
Comment 5 mpournakas_p 2015-12-10 14:13:44 UTC
github where?
Comment 6 Cody Russell 2015-12-10 15:41:56 UTC
We're trying to get it into an upcoming release. You'll get it automatically.
Comment 7 Rajneesh Kumar 2015-12-14 18:29:38 UTC
I have checked this issue with the following build:
MonoFramework-MDK-4.3.2.25.macos10.xamarin.universal_fca35d04554513bec878239e194469b5fe8f6519

Now I observed that I am able to input Japanese character successfully. Please refer the screencast: 

This issue has been fixed, however Japanese character gets disappears on clicking anywhere on the text editor and I have filed a bug for the same:
https://bugzilla.xamarin.com/show_bug.cgi?id=36987

Thanks..!
Comment 8 Lluis Sanchez 2016-01-11 11:04:36 UTC
*** Bug 36325 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.