Bug 35936 - Itermittent crash/hang with MonoTests.Mono.Unix.UnixSignalTest.TestWaitAny
Summary: Itermittent crash/hang with MonoTests.Mono.Unix.UnixSignalTest.TestWaitAny
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: General (show other bugs)
Version: unspecified
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Andi McClure
URL:
Depends on:
Blocks:
 
Reported: 2015-11-17 11:55 UTC by Andi McClure
Modified: 2015-11-24 14:07 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Andi McClure 2015-11-17 11:55:09 UTC
The Mono.Posix test are periodically failing on the builders. The reason for this is that MonoTests.Mono.Unix.UnixSignalTest.TestWaitAny sometimes crashes or hangs, at least on OS X. I have observed this on the builders running Yosemite and on my laptop running El Capitan, with Mono versions in the 4.3.1-4.4 range. It can quickly be observed by running:

while (cd mcs/class/Mono.Posix MONO_PATH=../../../mcs/class/lib/net_4_x ../../../runtime/mono-wrapper --debug ../../class/lib/net_4_x/nunit-console.exe  Mono.Posix_test_net_4_x.dll -noshadow -labels  -exclude=NotOnMac,NotWorking,ValueAdd,CAS,InetAccess -run=MonoTests.Mono.Unix.UnixSignalTest.TestWaitAny); do :; done

It will usually happen after about thirty repetitions. On attaching LLDB, the stack where the crash is reported as occurring will always be found to be trashed; if the application is run in LLDB to start, the problem does not appear to reproduce at all.
Comment 1 Andi McClure 2015-11-24 14:07:08 UTC
The SIGSEGV seen here is addressed by PR #2264.