Bug 35851 - F# with Xamarin.Mac Broken on 10.11
Summary: F# with Xamarin.Mac Broken on 10.11
Status: VERIFIED FIXED
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: Other (show other bugs)
Version: Master
Hardware: PC Mac OS
: High normal
Target Milestone: 2.8.0 (C7)
Assignee: Chris Hamons
URL:
Depends on:
Blocks:
 
Reported: 2015-11-13 18:03 UTC by Chris Hamons
Modified: 2015-12-16 19:24 UTC (History)
3 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Comment 1 Chris Hamons 2015-11-16 10:49:36 UTC
From QA:

I am getting this issue on EL Capitan
however its working fine on Yosemite

/Users/MM/Projects/trtrtrtrtrt/trtrtrtrtrt/FSC: Error FS0219: The referenced or default base CLI library 'mscorlib' is binary-incompatible with the referenced F# core library '/Library/Frameworks/Mono.framework/Versions/4.0.0/lib/mono/gac/FSharp.Core/4.3.1.0__b03f5f7f11d50a3a/FSharp.Core.dll'. Consider recompiling the library or making an explicit reference to a version of this library that matches the CLI version you are using. (FS0219) (trtrtrtrtrt)
Comment 2 Rajneesh Kumar 2015-11-16 11:05:51 UTC
I have checked this issue and able to reproduce this. Below are the supplement information:

Screencast: http://www.screencast.com/t/2ilwvvGu
Error Details : https://gist.github.com/Rajneesh360Logica/16e333cf876f84fcfa0e
Build Output: https://gist.github.com/Rajneesh360Logica/a5e86c0e7609b8e90fb3
Ide Logs : https://gist.github.com/Rajneesh360Logica/5e9a4427f677997e9e4d

Note: I am not able to reproduce this issue with the Unsupported Framework,  However I am getting another bug with Xamarin.Mac .Net 4.5 Framework, that is below: 

"/Users/Admin_Mac/Projects/BugTest_35851/BugTest_35851/MMP: Error MM1406: Target framework 'FSharp.Core.dll' is invalid when targetting Xamarin.Mac 4.5 .NET framwork. (MM1406) (BugTest_35851)"

Please let me know that if I can provide more information regarding this issue.

Thanks..!

Environemnt Info:


=== Xamarin Studio ===

Version 5.10 (build 871)
Installation UUID: 0b7eaebc-a0ed-4b58-81df-91e378cad28c
Runtime:
	Mono 4.2.1 (explicit/6dd2d0d)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 402010102

=== Xamarin.Profiler ===

Version: 0.0.0.0
Location: /Applications/XamarinProfiler.Mac.app/Contents/MacOS/XamarinProfiler.Mac

=== Apple Developer Tools ===

Xcode 7.1 (9079)
Build 7B91b

=== Xamarin.iOS ===

Version: 9.2.1.51 (Trial Edition)
Hash: 3c0ec35
Branch: master
Build date: 2015-11-12 13:05:39-0500

=== Xamarin.Android ===

Version: 6.0.0.34 (Trial Edition)
Android SDK: /Android SDK/android-sdk-macosx
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
		6.0    (API level 23)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.0.1
SDK Build Tools Version: 23.0.1

Java SDK: /usr
java version "1.7.0_25"
Java(TM) SE Runtime Environment (build 1.7.0_25-b15)
Java HotSpot(TM) 64-Bit Server VM (build 23.25-b01, mixed mode)

=== Xamarin Android Player ===

Version: 0.6.1
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: 2.4.0.109 (Trial Edition)

=== Build Information ===

Release ID: 510000871
Git revision: 4e9c5abb5ffdae12ba02ac49da83f8b2011dbb88
Build date: 2015-11-12 06:02:54-05
Xamarin addins: 55007ed0e56436f385d8e26394a45be563abc7e8
Build lane: monodevelop-lion-cycle6

=== Operating System ===

Mac OS X 10.11.0
Darwin Admin-Macs-Mac-mini.local 15.0.0 Darwin Kernel Version 15.0.0
    Wed Aug 26 16:57:32 PDT 2015
    root:xnu-3247.1.106~1/RELEASE_X86_64 x86_64
Comment 3 Chris Hamons 2015-11-17 15:58:03 UTC
Looks like we're not shipping the libraries?

3.2$ ls /Library/Frameworks/Xamarin.Mac.framework/Versions/Current/lib/mono/Xamarin.Mac/FSharp.Core.dll
/Library/Frameworks/Xamarin.Mac.framework/Versions/Current/lib/mono/Xamarin.Mac/FSharp.Core.dll
bash-3.2$ ls /Library/Frameworks/Xamarin.Mac.framework/Versions/
2.4.0.105 Current
bash-3.2$ ls /Library/Frameworks/Xamarin.Mac.framework/Versions/
2.4.0.109 Current
bash-3.2$ ls /Library/Frameworks/Xamarin.Mac.framework/Versions/Current/lib/mono/Xamarin.Mac/FSharp.Core.dll
ls: /Library/Frameworks/Xamarin.Mac.framework/Versions/Current/lib/mono/Xamarin.Mac/FSharp.Core.dll: No such file or directory
Comment 5 Rajneesh Kumar 2015-11-18 12:12:01 UTC
 I have checked this issue on 3 Yosemite machines and observed that this issue is working fine on one machine, however on others two machine I am getting same behavior as on EL Capitan. Below are the working environemnt and Non-Working environment info.



Yosemite Working Environemnt :
https://gist.github.com/Rajneesh360Logica/d813932ef26075d39fa5
Screencast: http://www.screencast.com/t/73LnkXRKahb



Yosemite Non-Working Environment :
https://gist.github.com/Parmendrak/50ce593cc86fa128c525
Screencast: http://www.screencast.com/t/NZXm9dy8

This issue was introduced previously and I have verified it with master builds. https://bugzilla.xamarin.com/show_bug.cgi?id=28738#c11

Thanks..!
Comment 6 Chris Hamons 2015-11-18 12:19:43 UTC
Fixed in master / e7cb761a868207a341e5fc0a128bb5aa9525db19.

Will likely be fixed in the first service release of Cycle 6.
Comment 7 Rajneesh Kumar 2015-11-18 13:06:48 UTC
I have checked this issue with the following master build:
xamarin.mac-2.5.0.2282_e7cb761a868207a341e5fc0a128bb5aa9525db19

I observed that I am successfully able to build and run the Xamarin.Mac F# Unified API application on EL Capitan and Yosemite machines. 

Screencast EL Capitan: http://www.screencast.com/t/1ZJODnLKHE6

Screencast Yosemite : http://www.screencast.com/t/NKHedby9V2

This issue has been fixed in master build, I will Re-Verify this issue when it will merged in Release branch.

Changing its status to Resolved Fixed.

Thanks..!

Environment Info: https://gist.github.com/Rajneesh360Logica/8df1fc421462ef719ca2
Comment 8 Rajneesh Kumar 2015-12-16 19:24:09 UTC
I have checked this issue with the following C6SR1 build:
xamarin.mac-2.4.1.4_fe82fc3f80eb584583e2c1934c760425dc42d29b

I observed that I am successfully able to build and run the Xamarin.Mac F# Unified API application using all three frameworks. 

Screencast: http://www.screencast.com/t/MgsAvr8mQOIG

This issue has been fixed , hence I am closing this issue.


Thanks..!

Note You need to log in before you can comment on or make changes to this bug.