Bug 35756 - Access denied (XA0000)
Summary: Access denied (XA0000)
Status: RESOLVED DUPLICATE of bug 14918
Alias: None
Product: Android
Classification: Xamarin
Component: Debugger (show other bugs)
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-11-10 17:45 UTC by Marc
Modified: 2015-11-23 14:47 UTC (History)
5 users (show)

Tags: BZCU
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 14918

Description Marc 2015-11-10 17:45:17 UTC
Hi everyone,

I am new at Xamarin and to learn I've started with the "Hello, Android" guide at "http://developer.xamarin.com/guides/android/getting_started/hello,android/" and after building the Phoneword App I get the next error:

C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(2,2): Error XA0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com. Reason: System.UnauthorizedAccessException: Access to the path "C:\Users\Marc Fernández" is denied. (XA0000)

Thank you very much for your help,

Marc Fernández
Comment 1 Al Clark [MSFT] 2015-11-22 15:13:30 UTC
Hi Marc!

I believe this is down to a limitation in Java in that it does not play nicely with accented characters in path names.  Please try moving your project to a folder that is not in your home directory, and ensuring that the Android SDK isn't contained within your home directory, and that the new folders do not contain any non-standard characters.

I hope that helps.

Kind regards,
Alan
Comment 2 Brendan Zagaeski (Xamarin Team, assistant) 2015-11-23 14:47:52 UTC

*** This bug has been marked as a duplicate of bug 14918 ***