Bug 35569 - Can not start inspector: Method 'UIDevice.get_Name' not found.
Summary: Can not start inspector: Method 'UIDevice.get_Name' not found.
Status: VERIFIED FIXED
Alias: None
Product: Workbooks & Inspector
Classification: Xamarin
Component: Agent: iOS (show other bugs)
Version: 0.3.1
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: inspectordev-discuss
URL:
Depends on:
Blocks:
 
Reported: 2015-11-05 04:14 UTC by Philipp
Modified: 2017-02-14 14:20 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Philipp 2015-11-05 04:14:56 UTC
When i try to start the inspector, the app crashes with the following exception:

System.MissingMethodException: Method 'UIDevice.get_Name' not found.
  at at Xamarin.InspectorSupport.<CreateAgent>m__1 () in /Users/builder/data/lanes/904/55ad6a51/source/inspector/Xamarin.Inspector.iOS/InspectorSupport.cs:line 17
  at at Foundation.NSAsyncActionDispatcher.Apply () in /Users/builder/data/lanes/2356/9ce9e8b9/source/maccore/src/Foundation/NSAction.cs:line 163
  at at (wrapper managed-to-native) UIKit.UIApplication:UIApplicationMain (int,string[],intptr,intptr)
  at at UIKit.UIApplication.Main (System.String[] args, IntPtr principal, IntPtr delegate) in /Users/builder/data/lanes/2356/9ce9e8b9/source/maccore/src/UIKit/UIApplication.cs:line 77
  at at UIKit.UIApplication.Main (System.String[] args, System.String principalClassName, System.String delegateClassName) in /Users/builder/data/lanes/2356/9ce9e8b9/source/maccore/src/UIKit/UIApplication.cs:line 61
Comment 1 Sandy Armstrong [MSFT] 2015-11-05 09:44:30 UTC
Hi Philipp. Could you please take a screenshot of your iOS project's "iOS Build" settings?

Mostly I'm curious about the linker settings (because I think disabling the linker might fix this for you), but it might be helpful to see all settings.

Thanks!
Comment 2 Jamie Houston 2015-11-05 15:25:33 UTC
I'm getting the same error.  I'll get a screenshot and try turning off the linker too.
Comment 3 Jamie Houston 2015-11-05 16:44:35 UTC
Changing build config to not link did the trick.  Error is gone.
Comment 4 Sandy Armstrong [MSFT] 2015-11-05 16:49:51 UTC
Excellent. As mentioned in the forums, in my own testing I also got a crash on startup, but with a different error. Fix is in the pipeline and will be in the next release.
Comment 5 Sandy Armstrong [MSFT] 2015-11-05 16:50:27 UTC
And by "fix" I mean we won't enable inspection unless the the linker is fully disabled.
Comment 6 Philipp 2015-11-06 07:28:07 UTC
Turning off the linker also worked for me. Thanks for the quick "fix" :)
Comment 7 Sandy Armstrong [MSFT] 2015-11-16 14:45:22 UTC
Fixed in upcoming release.