Bug 35559 - Error in using statement prevents any future code from running in the REPL
Summary: Error in using statement prevents any future code from running in the REPL
Status: RESOLVED DUPLICATE of bug 35604
Alias: None
Product: Workbooks & Inspector
Classification: Xamarin
Component: Client: Mac (show other bugs)
Version: 0.3.1
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: inspectordev-discuss
URL:
Depends on:
Blocks:
 
Reported: 2015-11-04 18:55 UTC by Matisse Hack
Modified: 2015-11-16 14:47 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Using screenshot (496.25 KB, image/png)
2015-11-04 18:55 UTC, Matisse Hack
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 35604

Description Matisse Hack 2015-11-04 18:55:50 UTC
Created attachment 13678 [details]
Using screenshot

This might be an issue with the Android agent, but after entering a bogus using statement into the REPL, I can't do anything more until I restart the app on the Android simulator. For example, when I enter:

> using System.DateTime;

I get:

(1,2): A `using' directive can only be applied to namespaces but `System.DateTime' denotes a type. Consider using a `using static' instead
(1,2): A `using' directive can only be applied to namespaces but `System.DateTime' denotes a type. Consider using a `using static' instead
(1,2): The using directive for `System.DateTime' appeared previously in this namespace

Clearly this is a dumb thing to enter into the REPL and the errors are all well and good (except maybe that they are duplicated). However, after entering this, anything I write into the REPL fails with that same error (see attached screenshot).
Comment 1 Sandy Armstrong [MSFT] 2015-11-04 20:30:55 UTC
Thanks, I remember seeing this issue in Sketches as well.

You can also see it with `csharp` on the command line (all of these use Mono.CSharp as the interactive compiler backend).
Comment 2 Sandy Armstrong [MSFT] 2015-11-05 18:21:45 UTC
I've filed bug #35604 to track the underlying issue.
Comment 3 Sandy Armstrong [MSFT] 2015-11-16 14:47:26 UTC
This fix will be part of future releases of Xamarin platform products.

*** This bug has been marked as a duplicate of bug 35604 ***