Bug 35554 - Smart Quotes prevents using strings in the REPL
Summary: Smart Quotes prevents using strings in the REPL
Status: RESOLVED FIXED
Alias: None
Product: Workbooks & Inspector
Classification: Xamarin
Component: Client: Mac (show other bugs)
Version: 0.3.1
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: inspectordev-discuss
URL:
Depends on:
Blocks:
 
Reported: 2015-11-04 17:45 UTC by Matisse Hack
Modified: 2015-11-13 12:34 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Proof (44.01 KB, image/png)
2015-11-04 17:45 UTC, Matisse Hack
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Matisse Hack 2015-11-04 17:45:31 UTC
Created attachment 13675 [details]
Proof

By default "Smart Quotes" is turned on inside the REPL. One can disable it through Edit > Substitutions > Smart Quotes, but by default you get some funny errors since the double quote is replaced by a version of the double quote that is slightly skewed. Therefore writing:

> selectedView.Text = “hi";

returns the error:

(1,22): Unexpected character `“'

After turning off Smart Quotes, typing:

selectedView.Text = "hi";

works just fine (note the first quote in that line is no longer angled slightly). Easy fix, but people might not know to turn off this option.
Comment 1 Sandy Armstrong [MSFT] 2015-11-04 17:58:17 UTC
I wonder if this is coming from a global setting; we haven't seen it yet. Thanks for finding it!
Comment 2 Matisse Hack 2015-11-04 18:16:08 UTC
Yes, I believe so. I have never touched it before though so it must be the default setting for everybody.
Comment 3 Sandy Armstrong [MSFT] 2015-11-04 18:25:26 UTC
Clearly not for *everybody*, but regardless, I'll make sure we're ignoring it in the REPL.
Comment 4 JW 2015-11-05 11:47:02 UTC
I've noticed this, as well.
Comment 5 Sandy Armstrong [MSFT] 2015-11-05 14:04:31 UTC
In System Preferences > Keyboard -> Text, is "Use smart quotes and dashes" checked?

I'm working on a fix, but want to make sure that that's the difference in our systems.
Comment 6 Sandy Armstrong [MSFT] 2015-11-05 14:26:39 UTC
Interesting...we do actually already disable this, but it only appears to take effect starting with the second run.
Comment 7 JW 2015-11-05 15:01:29 UTC
"In System Preferences > Keyboard -> Text, is "Use smart quotes and dashes"
checked?"

Yep, it's checked for me.
Comment 8 Matisse Hack 2015-11-05 18:22:58 UTC
Checked for me as well.

And I did notice that it seems to fix itself on subsequent launches.
Comment 9 Sandy Armstrong [MSFT] 2015-11-13 12:34:22 UTC
First run experience will be fixed in next release.