Bug 35529 - WebView.Eval throwing a NotImplementedException on WP8.1 (WinRT) (XF 1.5.1.6471)
Summary: WebView.Eval throwing a NotImplementedException on WP8.1 (WinRT) (XF 1.5.1.6471)
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows (show other bugs)
Version: 1.5.2
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-11-04 06:52 UTC by David Britch
Modified: 2016-05-02 12:49 UTC (History)
3 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments
Repro sample. (243.87 KB, application/zip)
2015-11-04 06:52 UTC, David Britch
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description David Britch 2015-11-04 06:52:44 UTC
Created attachment 13662 [details]
Repro sample.

When I use do a WebView.Eval (Xamarin.Forms WebView) I get a NotImplementedException in WinRT (phone). This appears to be because the WinRT WebViewRenderer is attempting to invoke Control.InvokeScript, when it should in fact be invoking Control.InvokeScriptAsync, as InvokeScript isn’t implemented for WP8.1 (WinRT).

Repro sample attached.
Comment 1 Jason Smith [MSFT] 2016-04-13 19:45:47 UTC
Should be fixed in 2.3.0-pre1
Comment 2 Parmendra Kumar 2016-05-02 12:49:48 UTC
I have checked this issue with Xamarin.Forms 2.3.0-pre2 and its working fine. I am successfully able to call javascript in WindowsPhone8.1 without any error.

Hence closing this issue.