Bug 35509 - System.Dns.GetHoseByName_internal core dump on Ubuntu 14.02
Summary: System.Dns.GetHoseByName_internal core dump on Ubuntu 14.02
Status: RESOLVED DUPLICATE of bug 30018
Alias: None
Product: Runtime
Classification: Mono
Component: io-layer (show other bugs)
Version: 4.2.0 (C6)
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-11-03 17:24 UTC by Aaron Stannard
Modified: 2015-11-03 18:43 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 30018

Description Aaron Stannard 2015-11-03 17:24:31 UTC
I'm able to produce the following core dump consistently and reliably using the latest version of NuGet.exe on Mono:

Cannot handle address family 32960
Stacktrace:

  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Net.Dns.GetHostByName_internal (string,string&,string[]&,string[]&) <0xffffffff>

  at System.Net.Dns.GetHostByName (string) <0x00047>
  at System.Net.ServicePoint.get_HostEntry () <0x001fb>
  at System.Net.WebConnection.Connect (System.Net.HttpWebRequest) <0x001af>
  at System.Net.WebConnection.InitConnection (object) <0x002fb>
  at System.Net.WebConnection.<WebConnection>m__0 (object) <0x0001f>
  at System.Threading.QueueUserWorkItemCallback.WaitCallback_Context (object) <0x00048>
  at System.Threading.ExecutionContext.RunInternal (System.Threading.ExecutionContext,System.Threading.ContextCallback,o
bject,bool) <0x0016e>
  at System.Threading.ExecutionContext.Run (System.Threading.ExecutionContext,System.Threading.ContextCallback,object,bo
ol) <0x00020>
  at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem () <0x00053>
  at System.Threading.ThreadPoolWorkQueue.Dispatch () <0x001d6>
  at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback () <0x00008>
  at (wrapper runtime-invoke) <Module>.runtime_invoke_bool (object,intptr,intptr,intptr) <0xffffffff>

Native stacktrace:

        mono() [0x49cf0c]
        /lib/x86_64-linux-gnu/libpthread.so.0(+0x10340) [0x7fdf5dac5340]
        /lib/x86_64-linux-gnu/libc.so.6(gsignal+0x39) [0x7fdf5d726cc9]
        /lib/x86_64-linux-gnu/libc.so.6(abort+0x148) [0x7fdf5d72a0d8]
        mono() [0x62a329]
        mono() [0x62a537]
        mono() [0x62a5e2]
        mono() [0x625375]
        mono() [0x576bee]
        [0x409a41e7]

Debug info from gdb:



=================================================================
Got a SIGABRT while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

Aborted (core dumped)


Reproduction steps: 

Download the latest X86 client from https://dist.nuget.org/index.html

Run nuget.exe list
Comment 1 Alexander Köplinger [MSFT] 2015-11-03 18:43:36 UTC
Looks like a duplicate of https://bugzilla.xamarin.com/show_bug.cgi?id=30018 (maybe try disabling ipv6 like mentioned in that bug?).

*** This bug has been marked as a duplicate of bug 30018 ***