Bug 35493 - WatchKit (watchOS 1) submissions rejected with "Invalid WatchKit Support"
Summary: WatchKit (watchOS 1) submissions rejected with "Invalid WatchKit Support"
Status: VERIFIED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: General (show other bugs)
Version: XI 9.1 (iOS 9.1)
Hardware: Macintosh Mac OS
: High blocker
Target Milestone: 9.1 (iOS 9.1)
Assignee: Vincent Dondain [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2015-11-03 08:26 UTC by Adam Hartley [MSFT]
Modified: 2015-11-10 10:19 UTC (History)
11 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Adam Hartley [MSFT] 2015-11-03 08:26:55 UTC
## Overview

Apps with a WatchKit extension and built with Xamarin.iOS 9.1.0.29 are hitting the below rejection.

The same app built with Xamarin.iOS 9.0.1.27 has been reported as being submitted successfully.

## Rejection message

Invalid WatchKit Support - The bundle contains an invalid implementation
of WatchKit. The app may have been built or signed with non-compliant or
pre-release tools. Visit developer.apple.com <http://developer.apple.com>
for more information.
Comment 2 Sebastien Pouliot 2015-11-03 11:42:41 UTC
@Gouri can QA confirm the issue ? Submission to the appstore is part of the release test plan so I would expect this was tested (but some details might differs).

@Christer can you provide all* the versions information on what you used (both working and non-working scenarios) ?

* The easiest way to get exact version information is to use the "Xamarin Studio" menu, "About Xamarin Studio" item, "Show Details" button and copy/paste the version informations (you can use the "Copy Information" button).
Comment 3 GouriKumari 2015-11-03 13:10:37 UTC
>>@Gouri can QA confirm the issue ? Submission to the appstore is part of the
>>release test plan so I would expect this was tested (but some details might
>>differs).

I can confirm with the alpha builds. 

Invalid WatchKit Support - The bundle contains an invalid implementation of WatchKit. The app may have been built or signed with non-compliant or pre-release tools. Visit developer.apple.com for more information.

Once these issues have been corrected, you can then redeliver the corrected binary."

Test Env:
=== Xamarin Studio ===

Version 5.10 (build 860)
Installation UUID: 5ed3a124-4b77-4c6f-beb9-c830fd815e2a
Runtime:
	Mono 4.2.1 (explicit/8862921)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 402010091


=== Apple Developer Tools ===

Xcode 7.1 (9079)
Build 7B91b

=== Xamarin.iOS ===

Version: 9.2.1.21 (Enterprise Edition)
Hash: 9ce9e8b
Branch: master
Build date: 2015-10-28 19:11:03-0400

=== Build Information ===

Release ID: 510000860
Git revision: 7c46a0b709d51ad5d5a5ed90a4671cc7b6928e62
Build date: 2015-10-29 17:17:52-04
Xamarin addins: b9337905aca5dc276190d78819728a59cda33a43
Build lane: monodevelop-lion-cycle6

=== Operating System ===

Mac OS X 10.10.5

Supplemental Info: This issue exists with stable as well, since I can reproduce the issue with Xamarin.iOS
Version: 9.1.0.27 (Enterprise Edition)
Hash: 1f068b4
Invalid WatchKit Support - The bundle contains an invalid implementation of WatchKit. The app may have been built or signed with non-compliant or pre-release tools. Visit developer.apple.com for more information.
Comment 4 Sebastien Pouliot 2015-11-03 13:23:19 UTC
@Vincent can you compare the .app we ship in both cases (XI 9.0 vs 9.1) ? and see what differs between them.

It's very unlikely to be related to bindings changes but there were quite a few changes for Xcode 7.1 (and WatchOS 2.0) for the msbuild tasks (or tooling) that could affect the final .app.
Comment 17 Mohit Kheterpal 2015-11-10 01:35:54 UTC
I am able to reproduce this issue with XVS 3.11.1589 + XI 9.1.0.29 and observe that, now we are not getting the rejection email when we upload ipa file of extension project to appstore.

I am using XVS 3.11.1594 + XI 9.1.0.39 and able to upload ipa file of extension project without getting rejection email.

As of Now, closing this issue by marking it as Verified.

Thanks
Comment 18 PJ 2015-11-10 10:19:53 UTC
> I am using XVS 3.11.1594 + XI 9.1.0.39 and able to upload ipa file of extension project without getting rejection email.

Correction: The build under test was monotouch-9.1.0.31 / bae2cdbe836e2e6ef017762757666693f2e424ac