Bug 35490 - Label Text Misaligned in Windows Phone 8.1 and WinRT (Xamarin Nuget Version 1.5.1.6471)
Summary: Label Text Misaligned in Windows Phone 8.1 and WinRT (Xamarin Nuget Version 1...
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows (show other bugs)
Version: 1.5.1
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: E.Z. Hart [MSFT]
URL:
: 36427 36686 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-11-03 04:56 UTC by Dharmendar
Modified: 2016-01-27 14:27 UTC (History)
6 users (show)

Tags: Windows ac
Is this bug a regression?: ---
Last known good build:


Attachments
Label Text Misaligned in Windows Phone 8.1 and WinRT (Xamarin Nuget Version 1.5.1.6471) (391.25 KB, application/zip)
2015-11-03 04:56 UTC, Dharmendar
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Dharmendar 2015-11-03 04:56:05 UTC
Created attachment 13628 [details]
Label Text Misaligned in Windows Phone 8.1 and WinRT (Xamarin Nuget Version 1.5.1.6471)

I have following scenario  which is working fine in Xamarin Forms Version 1.4.3.6376 but not in Version 1.5.1.6471

I have center aligned both X and Y position for a label, using XAlign and YAlign API's, but text is not center aligningin WinRT and WindowsPhone8.1 platforms. But it is center aligned in the Android, iOS and WindowsPhoneSilverlight8 platforms. Am using 1.5.1.6471 version of Xamarin nugets.

The same sample is working fine and the text is center aligned for all the platforms if I use Xamarin nugets of Version 1.4.3.6376.

I have attached a sample and a document containing the screenshots explaining the issue for your reference.

You can simply run the attached sample in both versions of Xamarin Nugets to reproduce the issue. Please let me know if you have concerns or doubts. 

I need this issue to be fixed immediately as my application is purely based on displaying the text in my custom views. Or any workaround to fix this issue is very much appreciated.
Comment 1 E.Z. Hart [MSFT] 2015-12-23 18:51:09 UTC
*** Bug 36686 has been marked as a duplicate of this bug. ***
Comment 2 E.Z. Hart [MSFT] 2015-12-23 18:52:09 UTC
*** Bug 36427 has been marked as a duplicate of this bug. ***
Comment 3 E.Z. Hart [MSFT] 2015-12-23 18:53:55 UTC
This is also occurring in Windows Phone 8.0
Comment 4 Rui Marinho 2016-01-04 20:13:03 UTC
Should be fixed in 2.0.2-pre1.
Comment 5 Dharmendar 2016-01-06 11:09:20 UTC
Is this fixed will be available in next release..?
Comment 6 Rui Marinho 2016-01-20 12:12:16 UTC
Correction Should be fixed in 2.1.0-pre1.
Comment 7 Parmendra Kumar 2016-01-27 14:27:18 UTC
I have checked this issue with Xamarin.Forms 2.1.0.6503-pre2 and its working fine.

Hence closing this issue.