Bug 35397 - Make the zip download of Android libraries more reliable
Summary: Make the zip download of Android libraries more reliable
Status: RESOLVED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild (show other bugs)
Version: 5.1
Hardware: All All
: --- normal
Target Milestone: ---
Assignee: dean.ellis
URL:
Depends on:
Blocks:
 
Reported: 2015-10-30 09:34 UTC by Rogier van der Hee
Modified: 2016-01-21 10:25 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Rogier van der Hee 2015-10-30 09:34:10 UTC
Whenever a library such as Forms changes its dependencies to a newer version of the support libraries, a new zip ala android_m2repository_r22 will be downloade to c:\users\<you>\AppData\Local\Xamarin 

A couple of problems in this regard:

1. The zip is downloaded for each version of the support library (CardView, MediaRouter etc etc). With the ever growing and expanding things in these libraries these get quite hefty (140mb plus at the moment). The zip is downloaded for every single library resulting in an unnecessary download of multiple 140mb plus files, which can be quite annoying when on a slow connection. 
This results in a very long first build time when this library needs to be downloaded 
2. Worse, there is no proper checking of whether the zip has downloaded / expanded correctly. This can result in all sorts of weird errors, such as errors in the Resource.Designer.cs complaining about missing resources id's. This is really BAD!
3. There is no visual clue what the build system is doing at this moment, it might be helpful to show that is downloading this stuff. I was really confused by what was happening and thought that Xamarin was hanging because I was waiting 10mins plus for a single build and broke it of (resulting in point 2 + a couple of hours of frustration of WTH was happening)).
Comment 1 Brendan Zagaeski (Xamarin Team, assistant) 2015-10-30 15:56:59 UTC
For bookkeeping I'll record that item 1 has its own bug report under Bug 32498.
Comment 2 dean.ellis 2016-01-21 10:12:06 UTC
Fixed in monodroid/master/b9ad35a0

Support has been added to allow the component team to set a Sha1sum for the file it is downloading. This will be compared against the sha1 of the file to make sure it is valid.

On top of this the Task responsible for downloading the files now has more verbose output which includes progress, so it should be clear in the Output window that the files are being downloaded.
Comment 3 Rogier van der Hee 2016-01-21 10:25:30 UTC
Great! Thanks for listening and fixing it