Bug 35272 - An HttpWebRequest was added to the ConnectionGroup queue because the connection limit was reached
Summary: An HttpWebRequest was added to the ConnectionGroup queue because the connecti...
Status: RESOLVED NORESPONSE
Alias: None
Product: Class Libraries
Classification: Mono
Component: General (show other bugs)
Version: 4.0.0
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-10-26 15:40 UTC by John Miller [MSFT]
Modified: 2018-03-13 11:07 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description John Miller [MSFT] 2015-10-26 15:40:55 UTC
**Overview:**

   Reusing a HttpClient and making many requests will lead connecting timeouts and no further requests with that client work. 

**Steps to Reproduce:**

   Need info on how to reproduce this. 

**Actual Results:**

   Connections timeout. There is also a WARNING message: 

An HttpWebRequest was added to the ConnectionGroup queue because the connection limit was reached

**Expected Results:**

   HttpClient is designed to be resused, but it seems doing this with many requests results in an error. 

**Build Date & Platform:**

   === Xamarin Studio ===

Version 5.9.7 (build 22)
Installation UUID: f9069a02-3ef7-498a-bef8-0fd31c8a8aba
Runtime:
Mono 4.0.4 ((detached/d481017)
GTK+ 2.24.23 (Raleigh theme)

Package version: 400040004

=== Apple Developer Tools ===

Xcode 7.0.1 (8228)
Build 7A1001

=== Xamarin.iOS ===

Version: 9.0.1.29 (Enterprise Edition)
Hash: 1d27ac2
Branch: master
Build date: 2015-09-25 18:08:44-0400

=== Xamarin.Android ===

Version: 5.1.7.12 (Enterprise Edition)
Android SDK: /Users/jaalvare/Library/Developer/Xamarin/android-sdk-macosx
Supported Android versions:
4.0.3 (API level 15)
4.4 (API level 19)
5.0 (API level 21)
5.1 (API level 22)
Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

=== Xamarin Android Player ===

Not Installed

=== Xamarin.Mac ===

Not Installed

=== Build Information ===

Release ID: 509070022
Git revision: 6bd1f169df44ca96addf8a035316c535a4fa46fa
Build date: 2015-09-30 12:30:15-04
Xamarin addins: 1c3e5c0859bdfec0ecd481a57ad6c03bc22f5536

=== Operating System ===

Mac OS X 10.10.5

**Additional Information:**

   Instead of reusing the HttpClient, if you create a new one each time, it will work.
Comment 1 Marek Safar 2018-03-13 11:07:24 UTC
We have not received the requested information. If you are still experiencing this issue please provide all the requested information and reopen the bug report.

Thank you!