Bug 35226 - NullReferenceException at System.Net.ServicePoint.CheckAvailableForRecycling
Summary: NullReferenceException at System.Net.ServicePoint.CheckAvailableForRecycling
Status: RESOLVED DUPLICATE of bug 32685
Alias: None
Product: Class Libraries
Classification: Mono
Component: System (show other bugs)
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-10-23 18:49 UTC by armin_willer
Modified: 2016-01-14 14:50 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 32685

Description armin_willer 2015-10-23 18:49:41 UTC
This is everything that was reporter by Xamarin Insight:

Message:
Object reference not set to an instance of an object
Stack Trace:
System.Net.ServicePoint.CheckAvailableForRecycling(System.DateTime& outIdleSince)
System.Net.ServicePoint.IdleTimerCallback(System.Object obj)
System.Threading.Timer+Scheduler.TimerCB(System.Object o)
Comment 1 armin_willer 2015-10-23 18:56:36 UTC
I could not reproduce the error and it only happens to people who downloaded our app in the store. Therefore I can't really provide anything helpful to find a solution for this.
Comment 2 Tom Philpot 2015-10-27 11:55:44 UTC
Possible duplicate of https://bugzilla.xamarin.com/show_bug.cgi?id=32685?
Comment 3 armin_willer 2015-10-28 07:16:35 UTC
That's what I thought but the other one is marked as resolved fixed, so this seems to be another reason for the same bug.
Comment 4 chorsfield 2015-11-19 13:57:06 UTC
Tableau has an app that is hitting this same issue in the store. 400 hits in 30 days. Note this happens on app resume paths. 


System.NullReferenceExceptionObject reference not set to an instance of an object
Raw


  at System.Net.ServicePoint.CheckAvailableForRecycling (System.DateTime& outIdleSince) [0x00000] in <filename unknown>:0 
  at System.Net.ServicePoint.IdleTimerCallback (System.Object obj) [0x00000] in <filename unknown>:0 
  at System.Threading.Timer+Scheduler.TimerCB (System.Object o) [0x00000] in <filename unknown>:0 



Properties & Custom Values



HResult
-2147467261
 

TargetSite
CheckAvailableForRecycling
Comment 5 Marek Safar 2016-01-14 14:50:36 UTC

*** This bug has been marked as a duplicate of bug 32685 ***