Bug 35159 - [IOS 9.1] Getting build error on building the watchkit application using Xcode 6.x
Summary: [IOS 9.1] Getting build error on building the watchkit application using Xcod...
Status: RESOLVED ANSWERED
Alias: None
Product: iOS
Classification: Xamarin
Component: General (show other bugs)
Version: XI 9.1 (iOS 9.1)
Hardware: PC Mac OS
: High critical
Target Milestone: 9.1 (iOS 9.1)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-10-22 08:13 UTC by Rajneesh Kumar
Modified: 2015-10-22 13:37 UTC (History)
7 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Comment 1 Rolf Bjarne Kvinge [MSFT] 2015-10-22 09:25:21 UTC
I think this can be solved with "we don't support Mavericks anymore".
Comment 2 Rolf Bjarne Kvinge [MSFT] 2015-10-22 09:27:01 UTC
However this sounds like something that depends on the Xcode version, not the OS version

@Rajneesh: did you test with the same Xcode version (6.2) on all OS X versions?
Comment 3 Rajneesh Kumar 2015-10-22 09:41:22 UTC
@Rolf, I have checked this issue on OS X 10.10.5 with Xcode 6.2 and I am observing the same behavior. So in my observation it seems that issue exist with Xcode 6.2 .

Thanks..!
Comment 4 Sebastien Pouliot 2015-10-22 10:55:48 UTC
@Rajneesh Out of curiosity does this works with XI 9.0.x ? 

XI 9.2 already states:

> Due to non-backward compatible changes in Xcode7 toolchain this version
> of Xamarin.iOS is only supported when used with Xcode 7 or later. This indirectly
>  means the oldest version of iOS that applications can be directly deployed
> (on devices) is iOS 6.

and that will need to be updated when it's refreshed for Xcode 7.1.

Right now (not pushed publicly) XI 9.1 release notes says

> You will need to use Mac OSX 10.10.4 (Yosemite) or newer to run this version
> of Xamarin.iOS along with Xcode 7.1.

which can be interpreted in several ways.
Comment 8 Sebastien Pouliot 2015-10-22 13:37:52 UTC
Release notes updated to require Xcode 7.x (which means 10.10.4 minimally for customers using Xcode 7.0).

That indirectly solve the issue (with Xcode 6.x) and we already know that (for other reasons) our upcoming XI 9.2 (C6) requires Xcode 7.x anyway.

Note You need to log in before you can comment on or make changes to this bug.