Bug 34994 - [Xamarin Studio] Dialogs do not highlight default ["Return"] button on Mac
Summary: [Xamarin Studio] Dialogs do not highlight default ["Return"] button on Mac
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General (show other bugs)
Version: 5.10 (C6SR3)
Hardware: Macintosh Mac OS
: Normal enhancement
Target Milestone: (C8SR1)
Assignee: Vsevolod Kukol
URL:
Depends on:
Blocks:
 
Reported: 2015-10-16 18:29 UTC by Andi McClure
Modified: 2016-07-07 17:58 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Only when all things have been painted blue can a perfect world society be attained (734.25 KB, image/png)
2015-10-16 18:29 UTC, Andi McClure
Details

Description Andi McClure 2015-10-16 18:29:05 UTC
Created attachment 13407 [details]
Only when all things have been painted blue can a perfect world society be attained

On Mac, the "default" button in a dialog (the one which will activate if you press the "return" key) is highlighted in a special way. As of El Capitan this is done by highlighting the default button blue, but this has been present in some form since at least System 6 and it is an extremely expected part of the mac user experience. Xamarin has dialogs which have a default button you can activate by pressing "return" but it is not highlighted.

Reproduction steps: Running Xamarin Studio Mac [XS 5.10 Build 811, OS X 10.11 15A284] I click File->New->Solution. A dialog pops up. There are multiple buttons, but none have the "default" styling. I hit "return". "Next" is automatically selected, so it apparently is the default button.

Expected behavior: "Next" should be blue.

Observed behavior: "Next" looks the same as "Cancel". Screenshot attached.

You can see the correct behavior in basically any system dialog on the mac, such as Edit->Start Dictation... in Finder.

If this is a GTK problem rather than a Xamarin Studio problem, it should be fixed in GTK also.
Comment 1 Lluis Sanchez 2015-10-19 14:36:25 UTC
To be fixed in GTK.
Comment 2 Vsevolod Kukol 2016-07-05 15:07:32 UTC
This should work correctly in XS 6.X.

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.


Create a new report for Bug 34994 on Developer Community or GitHub if you have new information to add and do not yet see a matching report.

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments


Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Related Links: