Bug 34797 - SIGSEGV when building an iOS app from mdtool
Summary: SIGSEGV when building an iOS app from mdtool
Status: RESOLVED DUPLICATE of bug 28398
Alias: None
Product: iOS
Classification: Xamarin
Component: General (show other bugs)
Version: XI 9.2
Hardware: Macintosh Mac OS
: --- major
Target Milestone: 9.2 (C6)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-10-13 02:56 UTC by Prashant Cholachagudda
Modified: 2015-11-16 16:29 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 28398

Description Prashant Cholachagudda 2015-10-13 02:56:25 UTC
When building multiple projects in serial customer sometimes encounter a SIGSEGV crash on the CI server.

'/Applications/Xamarin Studio.app/Contents/MacOS/mdtool' -v build --configuration:AppStore ./Rumble.sln -p:Rumble.Touch
Xamarin Studio Build Tool
Loading solution: /Users/Shared/Jenkins/Home/jobs/RND-iOSBuild_NEXT/workspace/Rumble.sln
   Loading solution: /Users/Shared/Jenkins/Home/jobs/RND-iOSBuild_NEXT/workspace/Rumble.sln
      Loading projects ..
Stacktrace:

  at <unknown> <0xffffffff>
  at Mono.Security.Protocol.Tls.ClientRecordProtocol.GetMessage (Mono.Security.Protocol.Tls.Handshake.HandshakeType) [0x00000] in /private/tmp/source-mono-mac-4.0.0-bug-33585-hotfix/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.4/mcs/class/Mono.Security/Mono.Security.Protocol.Tls/ClientRecordProtocol.cs:50
  at Mono.Security.Protocol.Tls.RecordProtocol.BeginSendRecord (Mono.Security.Protocol.Tls.Handshake.HandshakeType,System.AsyncCallback,object) [0x00000] in /private/tmp/source-mono-mac-4.0.0-bug-33585-hotfix/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.4/mcs/class/Mono.Security/Mono.Security.Protocol.Tls/RecordProtocol.cs:719
  at Mono.Security.Protocol.Tls.SslClientStream.BeginNegotiateHandshake (System.AsyncCallback,object) [0x0004c] in /private/tmp/source-mono-mac-4.0.0-bug-33585-hotfix/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.4/mcs/class/Mono.Security/Mono.Security.Protocol.Tls/SslClientStream.cs:411
  at Mono.Security.Protocol.Tls.SslStreamBase.BeginNegotiateHandshake (Mono.Security.Protocol.Tls.SslStreamBase/InternalAsyncResult) [0x00021] in /private/tmp/source-mono-mac-4.0.0-bug-33585-hotfix/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.4/mcs/class/Mono.Security/Mono.Security.Protocol.Tls/SslStreamBase.cs:488
  at Mono.Security.Protocol.Tls.SslStreamBase.BeginWrite (byte[],int,int,System.AsyncCallback,object) [0x0007f] in /private/tmp/source-mono-mac-4.0.0-bug-33585-hotfix/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.4/mcs/class/Mono.Security/Mono.Security.Protocol.Tls/SslStreamBase.cs:827
  at System.Net.WebConnection.BeginWrite (System.Net.HttpWebRequest,byte[],int,int,System.AsyncCallback,object) [0x0005f] in /private/tmp/source-mono-mac-4.0.0-bug-33585-hotfix/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.4/mcs/class/System/System.Net/WebConnection.cs:1054
  at System.Net.WebConnectionStream.SetHeadersAsync (System.Net.SimpleAsyncResult,bool) [0x0014b] in /private/tmp/source-mono-mac-4.0.0-bug-33585-hotfix/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.4/mcs/class/System/System.Net/WebConnectionStream.cs:663
  at System.Net.WebConnectionStream/<SetHeadersAsync>c__AnonStorey0.<>m__0 (System.Net.SimpleAsyncResult) [0x00000] in /private/tmp/source-mono-mac-4.0.0-bug-33585-hotfix/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.4/mcs/class/System/System.Net/WebConnectionStream.cs:639
  at System.Net.SimpleAsyncResult.Run (System.Net.SimpleAsyncFunc,System.Net.SimpleAsyncCallback) [0x00007] in /private/tmp/source-mono-mac-4.0.0-bug-33585-hotfix/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.4/mcs/class/System/System.Net/SimpleAsyncResult.cs:70
  at System.Net.WebConnectionStream.SetHeadersAsync (bool,System.Net.SimpleAsyncCallback) [0x00014] in /private/tmp/source-mono-mac-4.0.0-bug-33585-hotfix/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.4/mcs/class/System/System.Net/WebConnectionStream.cs:639
  at (wrapper remoting-invoke-with-check) System.Net.WebConnectionStream.SetHeadersAsync (bool,System.Net.SimpleAsyncCallback) <IL 0x0003a, 0xffffffff>
  at System.Net.HttpWebRequest.SetWriteStream (System.Net.WebConnectionStream) [0x00047] in /private/tmp/source-mono-mac-4.0.0-bug-33585-hotfix/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.4/mcs/class/System/System.Net/HttpWebRequest.cs:1283
  at (wrapper remoting-invoke-with-check) System.Net.HttpWebRequest.SetWriteStream (System.Net.WebConnectionStream) <IL 0x00039, 0xffffffff>
  at System.Net.WebConnection.InitConnection (object) [0x000d9] in /private/tmp/source-mono-mac-4.0.0-bug-33585-hotfix/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.4/mcs/class/System/System.Net/WebConnection.cs:799
  at System.Net.WebConnection.<WebConnection>m__0 (object) [0x00000] in /private/tmp/source-mono-mac-4.0.0-bug-33585-hotfix/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.4/mcs/class/System/System.Net/WebConnection.cs:124
  at (wrapper runtime-invoke) <Module>.runtime_invoke_void__this___object (object,intptr,intptr,intptr) <IL 0x00062, 0xffffffff>

Native stacktrace:


Debug info from gdb:

(lldb) command source -s 1 '/tmp/mono-gdb-commands.MRIRwm'

=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.
=================================================================



#  Version information:

=== Xamarin Studio ===

Version 5.9.7 (build 9)
Installation UUID: e2b1266c-a7b8-41b5-8aea-13e998ac1062
Runtime:
Mono 4.0.4 ((detached/d481017)
GTK+ 2.24.23 (Raleigh theme)

Package version: 400040004

=== Xamarin.Android ===

Version: 5.1.6.7 (Enterprise Edition)
Android SDK: /Users/jenkins/Library/Developer/Xamarin/android-sdk-macosx
Supported Android versions:
2.3 (API level 10)
4.0.3 (API level 15)
4.2 (API level 17)
4.4 (API level 19)
5.0 (API level 21)
5.1 (API level 22)
Java SDK: /usr
java version "1.7.0_79"
Java(TM) SE Runtime Environment (build 1.7.0_79-b15)
Java HotSpot(TM) 64-Bit Server VM (build 24.79-b02, mixed mode)

=== Xamarin Android Player ===

Not Installed

=== Apple Developer Tools ===

Xcode 6.4 (7720)
Build 6E35b

=== Xamarin.iOS ===

Version: 9.0.1.20 (Enterprise Edition)
Hash: d8e9592
Branch: master
Build date: 2015-09-18 23:22:05-0400

=== Xamarin.Mac ===

Not Installed

=== Build Information ===

Release ID: 509070009
Git revision: 31fa64709030b3edb971237780a452a4c69943c4
Build date: 2015-09-17 11:44:37-04
Xamarin addins: b105d33d8cd72911ff2cf3ee0b7715d37e5f19a6

=== Operating System ===

Mac OS X 10.10.4
Darwin JenkinsMacPro.local 14.4.0 Darwin Kernel Version 14.4.0
Thu May 28 11:35:04 PDT 2015
root:xnu-2782.30.5~1/RELEASE_X86_64 x86_64
Comment 2 Rolf Bjarne Kvinge [MSFT] 2015-10-13 05:58:15 UTC

*** This bug has been marked as a duplicate of bug 28398 ***
Comment 3 GouriKumari 2015-11-16 16:29:34 UTC
Bug 30859 (duplicate of bug 28398)  is verified on wrench lanes and the crash is no longer occurring with mono 4.2.0. 

@Prashanth: Could you verify the issue from your end as well.