Bug 34774 - Crash when pInvoking a C function with a string parameter on El Capitan
Summary: Crash when pInvoking a C function with a string parameter on El Capitan
Status: RESOLVED DUPLICATE of bug 35416
Alias: None
Product: Runtime
Classification: Mono
Component: General (show other bugs)
Version: 4.0.0
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-10-12 14:46 UTC by Steve Baer
Modified: 2018-01-05 14:56 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 35416

Description Steve Baer 2015-10-12 14:46:31 UTC
Please see https://github.com/mcneel/mono_embed for a sample to reproduce.

This sample embeds a 64 bit mono runtime and executes a method written in C#. The C# method in turn calls two exported C functions (one that takes an int and a double as parameters and one that takes a string).

On Yosemite / Xcode 6.4 this sample runs with no errors

On El Capitan / Xcode 7 this sample crashes when attempting to debug inside of Xcode. The crash occurs when trying to call the C function with a string parameter. When the Xcode debugger is NOT attached, this sample also runs with no problems on El Capitan.
Comment 1 Chris Hamons 2015-11-19 16:10:34 UTC
Assigning to alexrp@xamarin.com since they have two other possibly related bugs. Please feel free to ignore my assigning guess however.
Comment 3 Ludovic Henry 2018-01-05 14:56:51 UTC

*** This bug has been marked as a duplicate of bug 35416 ***