This is Xamarin's bug tracking system. For product support, please use the support links listed in your Xamarin Account.
Bug 34750 - Debugger crash very often - debugger-agent.c:2587, condition `res' not met
Summary: Debugger crash very often - debugger-agent.c:2587, condition `res' not met
Status: VERIFIED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: Debugger (show other bugs)
Version: 6.0.99
Hardware: PC All
: High major
Target Milestone: 6.0 (C6)
Assignee: Rodrigo Kumpera
URL:
: 34851 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-10-11 07:40 UTC by Przemysław Raciborski
Modified: 2015-10-29 05:54 UTC (History)
7 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Przemysław Raciborski 2015-10-11 07:40:45 UTC
Xamarin.Android 6.0 cycle 6, Windows - Visual Studio 2013 / 2015

Debugger very often crash, output log:
[] * Assertion at /Users/builder/data/lanes/2098/f94dc5b2/source/mono/mono/mini/debugger-agent.c:2587, condition `res' not met
[libc] Fatal signal 6 (SIGABRT), code -6 in tid 31229 (IntentService[n)

I can not submit reproduction sample. I would have to submit whole application - which I can not do. I'm also not sure what it is caused by - but crashes often occur on Activity where I use Google maps ( google maps v3 ). 

I am not the only who has such problems, this bug is mentioned by several people on Xamarin Forums - https://forums.xamarin.com/discussion/52444/alpha-release-xamarin-android-6-0-cycle-6-feature-release
Comment 1 Rodrigo Kumpera 2015-10-13 18:45:12 UTC
Tentative fix in a PR https://github.com/mono/mono/pull/2133

Now working to get this into the QA hands.
Comment 2 Arpit Jha 2015-10-14 07:14:43 UTC
I have checked this issue and able to reproduce this issue with Xamarin.VisualStudio_4.0.0.1582_41e70e415e01176e092fa0c0995664376ce0b600.msi

Steps I have followed to reproduce this issue.
1.Download and open TvLeanBack in VS Sample from https://github.com/xamarin/monodroid-samples/tree/master/tv/TvLeanback
2.Build and deploy the application.
3.App deployed successfully on device.
4.Switching on Video in App.
5.App gets crashed.


Supplement Info:
Screencast: http://www.screencast.com/t/klbz2YM6hSL
VS IDE log: https://gist.github.com/Arpit360/e48bd6fdf23f71ea3a3e
adb logcat: https://gist.github.com/Arpit360/61defccb1522c62ebe39
App output: https://gist.github.com/Arpit360/4285ba256b29a1277f40

Device: Moto Nexus 6 android 6.0

Note: We are getting same issue on mac as well with mono-android-6.0.0-13_4f0d1e9e7fd59c4c57046c9077c277180c2f5a8d 

I am changing Platform to all.

Environment Info:
https://gist.github.com/Arpit360/10fac6cf2a6ebc09efaa
Comment 3 Shruti 2015-10-14 07:25:42 UTC
*** Bug 34851 has been marked as a duplicate of this bug. ***
Comment 4 Abhishek 2015-10-14 11:23:50 UTC
I have checked this issue with the mono-android-6.0.0-16. This issue is working fine on Mac XS. I am not seeing any crashes while switching video tab. Here is the screencast for the same:
http://www.screencast.com/t/4PFJtXli9Au.

I will verify this issue once its fixed on Windows also as we are getting the same crashes on Windows VS and XS.

Thanks!
Comment 5 Peter Collins 2015-10-22 15:09:21 UTC
There is now an XVS build which also contains this fin in xamarinvs/cycle6/2ddfb33.
Comment 6 Peter Collins 2015-10-22 15:14:26 UTC
The last comment was incorrect, however we've since tested and confirmed this fix against a cycle6-based pr build of XA and XVS.
Comment 7 Arpit Jha 2015-10-29 05:54:39 UTC
******************************
Verify Status:
******************************

I have checked this issue with tvLeanback monodroid sample with latest Cycle 6 build(XVS 4.0.0.1642(24a6538)  + XA 6.0.0.24 on windows and mac machine and observed that this issue is working fine . Now I am not observing any app getting crashed.

Screencast:
Windows:http://www.screencast.com/t/1dR9SEqNk2o 
Mac: http://www.screencast.com/t/VI1TsIoPS9nA

Environment Info: 
Windows : https://gist.github.com/Abhishekk360/0ac5de2abdcd875ef6ec
Mac: https://gist.github.com/Abhishekk360/d22d41dded3252aa6304
 
Hence closing this issue

Note You need to log in before you can comment on or make changes to this bug.