Bug 34612 - F# Interactive pad terminates session: "mono: not found" (El Capitan)
Summary: F# Interactive pad terminates session: "mono: not found" (El Capitan)
Status: RESOLVED DUPLICATE of bug 34470
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: F# Add-in (show other bugs)
Version: 5.10 (C6SR3)
Hardware: PC Mac OS
: --- normal
Target Milestone: 5.10 (C6)
Assignee: Jason Imison
URL:
Depends on:
Blocks:
 
Reported: 2015-10-06 18:45 UTC by Larry O'Brien
Modified: 2015-10-13 12:41 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 34470

Description Larry O'Brien 2015-10-06 18:45:08 UTC
I upgraded to El Capitan on Friday. I installed XS today: 

Xamarin Studio
Version 5.10 (build 913)
Installation UUID: 36314227-811f-4808-b811-644922ae7081
Runtime:
	Mono 4.2.1 (explicit/804ddbc)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 402010060

On the command-line, I can access mono and fsharpi:

$ which mono fsharpi
/usr/local/bin/mono
/usr/local/bin/fsharpi

When I attempt to view the F# Interactive pad, I receive:

Session termination detected. Press Enter to restart.

/Library/Frameworks/Mono.framework/Versions/4.2.1/bin/fsharpi: line 24: exec: mono: not found

If I press "Enter" to restart, I receive the same message.
Comment 1 Alexis Christoforides 2015-10-13 12:41:59 UTC

*** This bug has been marked as a duplicate of bug 34470 ***