Bug 34409 - XML document generation
Summary: XML document generation
Status: RESOLVED FIXED
Alias: None
Product: Compilers
Classification: Mono
Component: C# (show other bugs)
Version: 3.12.0
Hardware: Other Linux
: --- normal
Target Milestone: ---
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2015-09-29 13:31 UTC by David Newman
Modified: 2015-10-05 10:08 UTC (History)
3 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description David Newman 2015-09-29 13:31:21 UTC
mono strips out leading whitespace and blank lines when generating XML documentation files. This behavior is different from Visual Studio on Windows, and, as a result, formatting is lost in the generated files.
Comment 1 David Newman 2015-09-29 13:39:32 UTC
For example, a comment like the following:
///<text>
///A line
///
///   An indented line
///</text>

looks like this in the XML file:
<text>
A line
An indented line
</text>
Comment 2 Marek Safar 2015-10-05 10:08:38 UTC
Fixed in master

Notice (2018-05-21): bugzilla.xamarin.com will be switching to read-only mode on Thursday, 2018-05-25 22:00 UTC.

Please join us on Visual Studio Developer Community and GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs and copy them to the new locations as needed for follow-up. The See Also field on each Bugzilla bug will be updated with a link to its new location when applicable.

After Bugzilla is read-only, if you have new information to add for a bug that does not yet have a matching issue on Developer Community or GitHub, you can create a follow-up issue in the new location. Copy and paste the title and description from this bug, and then add your new details. You can get a pre-formatted version of the title and description here:

In special cases you might also want the comments:

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Note You need to log in before you can comment on or make changes to this bug.