Bug 34385 - Unhandled exception in finalizer will not terminate the app if there's an AppDomain.UnhandledException handler
Summary: Unhandled exception in finalizer will not terminate the app if there's an App...
Status: RESOLVED DUPLICATE of bug 39077
Alias: None
Product: Runtime
Classification: Mono
Component: General (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Ludovic Henry
URL:
Depends on: 34398
Blocks:
  Show dependency tree
 
Reported: 2015-09-29 06:02 UTC by Rolf Bjarne Kvinge [MSFT]
Modified: 2016-03-04 10:22 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 39077

Description Rolf Bjarne Kvinge [MSFT] 2015-09-29 06:02:54 UTC
Test case: https://gist.github.com/rolfbjarne/da71564c202c40ad8ff9

Run the test case.

It crashes on .NET and runs successfully on Mono.
Comment 1 Ludovic Henry 2016-03-04 10:22:22 UTC

*** This bug has been marked as a duplicate of bug 39077 ***