This is Xamarin's bug tracking system. For product support, please use the support links listed in your Xamarin Account.
Bug 34250 - All leaf-node menu items are disabled
Summary: All leaf-node menu items are disabled
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Shell (show other bugs)
Version: 5.10 (C6SR3)
Hardware: PC Mac OS
: Normal normal
Target Milestone: master
Assignee: iain
URL:
: 34530 35465 35807 36290 36827 37107 37472 37516 37650 37895 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-09-24 14:22 UTC by Aaron Bockover [MSFT]
Modified: 2016-02-18 11:52 UTC (History)
22 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Screenshot of activation error dialog (604.19 KB, image/png)
2015-09-24 14:22 UTC, Aaron Bockover [MSFT]
Details

Description Aaron Bockover [MSFT] 2015-09-24 14:22:16 UTC
Created attachment 13058 [details]
Screenshot of activation error dialog

This one is strange: http://screencast.com/t/2ex50PHI5P

It looks like every command is disabled. All leaf-node menu items are disabled.

Attached screenshot shows one menu. Screencast shows them all disabled.


Version Info:
=============

=== Xamarin Studio ===

Version 5.10 (build 799)
Installation UUID: 2701a58e-0630-4e42-b81d-229161066215
Runtime:
    Mono 4.2.1 (explicit/dbd6429)
    GTK+ 2.24.23 (Raleigh theme)

    Package version: 402010036

=== Xamarin.Profiler ===

Not Installed

=== Apple Developer Tools ===

Xcode 7.0 (8223)
Build 7A218

=== Xamarin.iOS ===

Version: 8.10.4.46 (Starter Edition)
Hash: 2c66d2f
Branch: master
Build date: 2015-08-04 13:52:25-0400

=== Xamarin.Android ===

Version: 5.1.5.3 (Starter Edition)
Android SDK: /Users/aaron/Library/Developer/Xamarin/android-sdk-macosx
    Supported Android versions:
        2.3   (API level 10)
        4.0.3 (API level 15)
        4.4   (API level 19)
        5.0   (API level 21)
        5.1   (API level 22)

SDK Tools Version: 24.3.2
SDK Platform Tools Version: 22
SDK Build Tools Version: 23.0.0

Java SDK: /usr
java version "1.8.0_40"
Java(TM) SE Runtime Environment (build 1.8.0_40-b27)
Java HotSpot(TM) 64-Bit Server VM (build 25.40-b25, mixed mode)

=== Xamarin Android Player ===

Version: 0.3.7
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: 2.4.0.68 (Starter Edition)

=== Build Information ===

Release ID: 510000799
Git revision: 324ed342c08e2d35c4738f5cbb99f43d57186f90
Build date: 2015-09-18 14:43:35-04
Xamarin addins: 97a862a9dcaa31e9044c8613ef42e0a588c8d012
Build lane: monodevelop-lion-cycle6

=== Operating System ===

Mac OS X 10.11.0
Darwin porkbelly.local 15.0.0 Darwin Kernel Version 15.0.0
    Wed Aug 26 16:57:32 PDT 2015
    root:xnu-3247.1.106~1/RELEASE_X86_64 x86_64
Comment 1 Lluis Sanchez 2015-09-25 06:46:42 UTC
How can this be reproduced?
Comment 2 Aaron Bockover [MSFT] 2015-09-25 13:10:36 UTC
I honestly have absolutely no idea how I got into that state. I quit XS and haven't seen it since. There wasn't anything obvious like a crash/stacktrace in the IDE log.
Comment 3 iain 2015-10-06 07:31:48 UTC
*** Bug 34530 has been marked as a duplicate of this bug. ***
Comment 4 iain 2015-10-06 07:33:54 UTC
There's logic to disable the menus when a modal dialog is on screen, it may be possible that some how this is failing to be cleared when the dialog is closed.
Comment 5 Neal 2015-10-06 10:21:57 UTC
I wonder if this is associated with the SIM showing the select application during debugging problem too? 

https://forums.xamarin.com/discussion/51676/where-is-ios-simulator-message-while-debugging
Comment 6 Aaron Bockover [MSFT] 2015-10-07 11:26:28 UTC
Just ran into this again, but still not sure what I may have done to trigger it. The last thing I did was run the updater. It errored out "Error retrieving update information." Then I clicked "Close" and noticed that all the leaf node menu items were disabled again.
Comment 7 Neal 2015-10-07 11:33:26 UTC
This morning the updater downloaded iOS and XS new stables but would hang on the install.  I had to reboot Mac with El Capitan and then run the install to work.  This happened on both of my Macs.
Comment 9 iain 2015-11-26 12:21:34 UTC
*** Bug 35465 has been marked as a duplicate of this bug. ***
Comment 10 iain 2015-11-26 12:22:07 UTC
*** Bug 35807 has been marked as a duplicate of this bug. ***
Comment 11 Mark Woollard 2015-12-03 07:50:41 UTC
Just to add I see this about once a day. It may be down to debugging and sitting on breakpoints or viewing variables in the popover dialog but am not sure on this as not clear exact steps. Just working debugging app and after a while find XS in this state. My first thought was modal dialog open hidden behind app or something but nothing is visible or shows if you enter 'F3' to go into window picker view of desktop.
Comment 12 Mark Woollard 2015-12-03 11:00:05 UTC
Have figured out at least one way to reproduce this issue, at least for me. Open a solution in XS. Then go File / Open... and choose a file that is not part of the solution you have open. Having done this all the leaf menus are disabled. I do this reasonably often to bring in files to XS from other projects for reference.
Comment 13 iain 2015-12-03 11:33:37 UTC
Mark: and you're using El Capitan as well?
Comment 14 Mark Woollard 2015-12-03 11:39:11 UTC
Correct - 10.11.2 Beta (15C27e)
Comment 15 iain 2015-12-07 17:48:19 UTC
One way to reproduce this seems to be to double click the References item in the Solution Pad and then use the Escape key to close the dialog. After that the menu items will be disabled
Comment 16 Shruti 2015-12-08 07:04:41 UTC
I am not able to reproduce this issue. I have taken following attempts to reproduce this issue:

Attempt 1: Double click the References item in the Solution Pad and then use the Escape key to close the dialog. (Not Reproduced)

Attempt 2: Open a solution in XS. Then go File / Open. Open .swf file. (Not Reproduced)

Attempt 3: Click on About Xamarin Studio. Dismiss the about window by clicking on the top-left red circle (MAC OS), not the 'close' button (Not Reproduced)

Attempt 4: Click on 'Check for Updates'. Channel starts update ton 'Xamarin Update' dialog box. Escape key to close the dialog

Attempt 5: Double click on .storyboard file to open it on IDE. Close .storyboard before loading designer.

I have tried to reproduce it with more scenarios but not get success.

Environment Info:
1. https://gist.github.com/Rajneesh360Logica/8b06d2f47e1da514b70b
2. https://gist.github.com/Rajneesh360Logica/ab92da46279cdd5da46e
3. XS 5.9.7 (build 22)
Comment 17 woot 2015-12-09 21:54:24 UTC
I have found an additional way to reproduce the issue (5.10.1 Build 6, stable, El Capitan).

1) Open a solution in Xamarin Studio.
2) Right click References -> Edit References
3) Select ".Net Assembly" tab
4) Select Browse button, choose a dll not in the current solution to add, select the dll
5) Press OK to add the assembly and close References dialog
6) Check Menu Items, most should be disabled
Comment 18 PJ 2015-12-11 15:44:22 UTC
*** Bug 36827 has been marked as a duplicate of this bug. ***
Comment 19 iain 2015-12-14 12:47:48 UTC
*** Bug 36290 has been marked as a duplicate of this bug. ***
Comment 20 Rajneesh Kumar 2015-12-14 17:27:09 UTC
I have checked this issue with the fix build XS 5.10.2 (build 40) provided in the bug
https://bugzilla.xamarin.com/show_bug.cgi?id=36827#c2, and I observed that I am no longer able to reproduce this issue with this build on OS X 10.11.0 and OS X 10.11.2. It seems that this issue has been fixed and working fine. Now Menues options are in enable mode and working according to their functionality.

Screencast: http://www.screencast.com/t/DGqzBT0t

As I am not observing/reproduce this issue at my end, hence I am changing its status to 
Resolved Fixed and I will Rr-Verify this issue when fix will merged in Release branch.

Environment Info: https://gist.github.com/Rajneesh360Logica/9cc07fda0f5960fd6802

Thanks..!
Comment 21 Lluis Sanchez 2015-12-17 11:49:51 UTC
*** Bug 37107 has been marked as a duplicate of this bug. ***
Comment 22 Rajneesh Kumar 2015-12-17 12:17:55 UTC
I have checked this issue with the following build from C6SR1:
XamarinStudio-5.10.2.48_60e81d8fc403b35205259dc04e3f8cb60d6eeedd


I observed that this issue has been fixed, and I am longer able to reproduce this issue with this build on OS X 10.11.0 and OS X 10.11.2. Now Menues options are in enable mode and working according to their functionality.

Screencast: http://www.screencast.com/t/6VXpEatPwf

As I am not observing/reproduce this issue at my end, hence I am closing this issue.
Also if anyone face this issue, please feel free to reopen this issue or filed a separate one.

Thanks..!
Comment 23 tkandiliotis 2015-12-27 13:00:51 UTC
It's still happening, it's NOT resolved :(

El Capitan 10.11.2
Xamarin Studio 5.10.1
Comment 24 Paul Johnson 2015-12-27 13:12:59 UTC
@tkandiliotis@gmail.com - it is fixed in 5.10.2 which can be found on the Alpha channel
Comment 25 atarr 2016-01-03 18:54:05 UTC
This also happens to me frequently. Menu items grayed out and have to force quit the application. 

El Capitan 10.11.2
Xamarin Studio 5.10.1
Comment 26 Lluis Sanchez 2016-01-08 16:35:40 UTC
*** Bug 37472 has been marked as a duplicate of this bug. ***
Comment 27 Lluis Sanchez 2016-01-08 17:23:05 UTC
*** Bug 37516 has been marked as a duplicate of this bug. ***
Comment 28 Joe Mellin 2016-01-08 20:56:42 UTC
Hey all, I have this as well.  It was happening to me multiple times per day, so I switched to Alpha.  

I will switch back and try to reproduce.
Comment 29 Max Xie 2016-01-10 05:58:06 UTC
By debug the source code of MonoDevelop, I have found the bug, please fix this method,
MacPlatform.MacPlatform.cs --> IsModalDialogRunning(),

return toplevels.Any (t => t.Key.IsVisible && (t.Value == null || t.Value.Modal) &&
				!(t.Key.DebugDescription.StartsWith("<NSStatusBarWindow", StringComparison.Ordinal) ||
					t.Key.DebugDescription.StartsWith ("<NSToolbarFullScreenWindow", StringComparison.Ordinal) ||
					t.Key.DebugDescription.StartsWith ("<NSCarbonMenuWindow", StringComparison.Ordinal)||
                    t.Key.DebugDescription.StartsWith ("<NSLimitedMenuViewWindow", StringComparison.Ordinal)
				));

on osx 10.11.2, it will become a new child window, NSLimitedMenuViewWindow, just ignore this window , it will be OK.
Comment 30 Lluis Sanchez 2016-01-11 10:45:48 UTC
Max, this has already been fixed. You can test it using XS 5.10.2, which is currently available in the alpha channel.
Comment 31 Lluis Sanchez 2016-01-14 16:54:33 UTC
*** Bug 37650 has been marked as a duplicate of this bug. ***
Comment 32 Matt Ward 2016-01-22 10:26:03 UTC
*** Bug 37895 has been marked as a duplicate of this bug. ***
Comment 33 Brandon Ramirez 2016-02-17 17:35:44 UTC
This is still an issue. I am using xamarin studio 5.10.2 on windows 7 and encountered this issue.

Steps to Reproduce:
* Open any xamarin.forms project
* Run the debugger with the xamarin android player (I am using Nexus 7 lollipop)
* Stop the debugger with the stop button in xamarin studio
* Run and stop the debugger once more, now the leaf nodes for the menu options at the top are gone, the file menu still works, but not the project or build menu
Comment 34 iain 2016-02-18 11:52:41 UTC
Hi Brandon, I've split your comments out into a separate bug: https://bugzilla.xamarin.com/show_bug.cgi?id=38871 , as this bug was related to the OS X version and the fix would be something different

Note You need to log in before you can comment on or make changes to this bug.