Bug 34063 - After software update today, cannot build iOS projects. Could not link assemblies. Reason: Can't not find the nested type
Summary: After software update today, cannot build iOS projects. Could not link assemb...
Status: RESOLVED DUPLICATE of bug 33124
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll (show other bugs)
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-09-18 12:25 UTC by John Hardman
Modified: 2015-09-18 15:18 UTC (History)
5 users (show)

See Also:
Tags: iOS link
Is this bug a regression?: ---
Last known good build:


Attachments

Description John Hardman 2015-09-18 12:25:35 UTC
Like multiple other people, after today's Xamarin and XCode updates, I can no longer build iOS projects from Visual Studio (I am using VS 2013). The following message is reported:

Could not link assemblies. Reason: Can't not find the nested type

The serious problem is that we cannot build.

The less serious problem is that the Reason contains a double negative.

For more details, see https://forums.xamarin.com/discussion/51100/ios-linker-error-cant-not-find-the-nested-type-when-built-in-visual-studio-but-not-xamarin-studio
Comment 1 Kevin Cherdch 2015-09-18 14:31:24 UTC
The file that I'm seeing this error is coming from 

C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.iOS.Common.targets on the following tag

<MTouch
SessionId="$(BuildSessionId)"
Condition="'$(MtouchTargetsEnabled)'"
ToolExe="$(MtouchExe)"
ToolPath="$(MtouchPath)"
AppBundleDir="$(AppBundleDir)"
...

It's complaining right on the MTouch tag.
Comment 2 Carl Barton 2015-09-18 14:42:43 UTC
I am receiving the same error about nested types with VS2013.

I verified that this also happens when using Xamarin Studio on Mac.

Others had stated that if you turn off linking it would work however with XS on Mac, it would just hang while building and required my to Force Quit.

I had updated all components to the latest Stable (XS, Xam.VS, Xam.iOS, Xcode7 + CommandLine Tools).
Comment 3 Sebastien Pouliot 2015-09-18 15:18:28 UTC
This seems to happen only in debug builds compiled with VS 2013.

*** This bug has been marked as a duplicate of bug 33124 ***

Note You need to log in before you can comment on or make changes to this bug.