Bug 34023 - Xamarin.Forms XAML IntelliSense does not work on the first attempt to autocomplete in the first XAML document loaded after starting VS
Summary: Xamarin.Forms XAML IntelliSense does not work on the first attempt to autocom...
Status: RESOLVED DUPLICATE of bug 57281
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Xamarin.Forms (show other bugs)
Version: 4.0.0 (C6)
Hardware: PC Windows
: Normal minor
Target Milestone: Future Cycle
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-09-16 19:23 UTC by Brendan Zagaeski (Xamarin Team, assistant)
Modified: 2017-06-21 19:48 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Test case (6.54 MB, application/zip)
2015-09-16 19:23 UTC, Brendan Zagaeski (Xamarin Team, assistant)
Details
Screen capture showing the problem (490.13 KB, application/x-shockwave-flash)
2015-09-16 19:23 UTC, Brendan Zagaeski (Xamarin Team, assistant)
Details
Additional VS version info (3.41 KB, text/plain)
2015-09-16 19:23 UTC, Brendan Zagaeski (Xamarin Team, assistant)
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 57281

Description Brendan Zagaeski (Xamarin Team, assistant) 2015-09-16 19:23:17 UTC
Created attachment 12921 [details]
Test case

Xamarin.Forms XAML IntelliSense does not work on the first attempt to autocomplete in the first XAML document loaded after starting VS




## Regression status: not a regression

XF XAML IntelliSense was a new feature in Cycle 5.

BAD: XamarinVS 4.0.0.1111 (a1dc0d5)
BAD: XamarinVS 3.11.894.0 (d70d139)




## Steps to reproduce

1. Double click the `.sln` file from the attached test case to open it in Visual Studio. (You could also create a new project from template, but Bug 34008 makes it inconvenient to add a XAML page on XVS 4.0.)

2. Click (or double-click) the `Page1.xaml` file.

3. Type the less-than < character to start a new element under the `ContentPage` element.




## Results

IntelliSense only offers the following autocompletions: 

> !--
> ![CDATA[
> ?




## Expected results

If you delete the opening `<` and then type it again, you get the expected full list of autocompletions:

> !--
> ![CDATA[
> ?
> AbsoluteLayout
> ActionSheetArguments
> ActivityIndicator
> AlertArguments

etc.




## Additional version info (brief)

Windows 8.1 (64-bit) in VMWare Fusion 6.0.6

Microsoft Visual Studio Professional 2013
Version 12.0.40629.00 Update 5
Microsoft .NET Framework
Version 4.6.00081
Comment 2 Brendan Zagaeski (Xamarin Team, assistant) 2015-09-16 19:23:52 UTC
Created attachment 12923 [details]
Additional VS version info
Comment 4 Daniel Cazzulino 2017-04-06 21:52:30 UTC
Is this still an issue? Also, since the XAML-based intellisense is now purely VS-driven (for VS2015+), I don't think we're going to invest anymore in our legacy one for VS2013...
Comment 5 Jon Goldberger [MSFT] 2017-04-10 18:55:44 UTC
I can still reproduce this using the attached test project, but not with a new form temp[late project. 

## Environment

Microsoft Visual Studio Enterprise 2015
Version 14.0.25431.01 Update 3
Microsoft .NET Framework
Version 4.6.01586

Installed Version: Enterprise

Architecture and Modeling Tools   00322-90001-97244-AA335
Microsoft Architecture and Modeling Tools
    
UML® and Unified Modeling Language™ are trademarks or registered trademarks of the Object Management Group, Inc. in the United States and other countries.

Microsoft Visual Studio Tools for Applications 2015   00322-90001-97244-AA335
Microsoft Visual Studio Tools for Applications 2015

Visual Basic 2015   00322-90001-97244-AA335
Microsoft Visual Basic 2015

Visual C# 2015   00322-90001-97244-AA335
Microsoft Visual C# 2015

Visual C++ 2015   00322-90001-97244-AA335
Microsoft Visual C++ 2015

Application Insights Tools for Visual Studio Package   7.18.00214.2
Application Insights Tools for Visual Studio

ASP.NET and Web Tools 2015.1   14.1.21111.0
ASP.NET and Web Tools 2015.1

ASP.NET Web Frameworks and Tools 2012.2   4.1.41102.0
For additional information, visit http://go.microsoft.com/fwlink/?LinkID=309563

ASP.NET Web Frameworks and Tools 2013   5.2.40314.0
For additional information, visit http://www.asp.net/

Azure App Service Tools v2.9.6   14.0.21111.0
Azure App Service Tools v2.9.6

Azure Data Lake Node   1.0
This package contains the Data Lake integration nodes for Server Explorer.

Azure Data Lake Tools for Visual Studio   2.2.2100.0
Microsoft Azure Data Lake Tools for Visual Studio

Common Azure Tools   1.8
Provides common services for use by Azure Mobile Services and Microsoft Azure Tools.

GitHub.VisualStudio   2.2.0.8
A Visual Studio Extension that brings the GitHub Flow into Visual Studio.

JavaScript Language Service   2.0
JavaScript Language Service

JavaScript Project System   2.0
JavaScript Project System

Merq   1.1.17-rc (cba4571)
Command Bus, Event Stream and Async Manager for Visual Studio extensions.

Microsoft .NET Core Tools (Preview 2)   14.1.21111.0
Microsoft .NET Core Tools (Preview 2)

Microsoft Azure Hive Query Language Service   2.2.2100.0
Language service for Hive query

Microsoft Azure Mobile Services Tools   1.4
Microsoft Azure Mobile Services Tools

Microsoft Azure Tools   2.9
Microsoft Azure Tools for Microsoft Visual Studio 2015 - v2.9.41104.6

Mono Debugging for Visual Studio   Mono.Debugging.VisualStudio
Support for debugging Mono processes with Visual Studio.

NuGet Package Manager   3.5.0
NuGet Package Manager in Visual Studio. For more information about NuGet, visit http://docs.nuget.org/.

PreEmptive Analytics Visualizer   1.2
Microsoft Visual Studio extension to visualize aggregated summaries from the PreEmptive Analytics product.

SQL Server Analysis Services   13.0.1701.8
Microsoft SQL Server Analysis Services Designer 
Version 13.0.1701.8

SQL Server Data Tools   14.0.61021.0
Microsoft SQL Server Data Tools

SQL Server Integration Services   
Microsoft SQL Server Integration Services Designer
Version 13.0.1601.5

SQL Server Reporting Services   13.0.1701.8
Microsoft SQL Server Reporting Services Designers 
Version 13.0.1701.8

ToolWindowHostedEditor   1.0
Hosting json editor into a tool window

TypeScript   1.8.36.0
TypeScript tools for Visual Studio

Visual Studio Tools for Universal Windows Apps   14.0.25527.01
The Visual Studio Tools for Universal Windows apps allow you to build a single universal app experience that can reach every device running Windows 10: phone, tablet, PC, and more. It includes the Microsoft Windows 10 Software Development Kit.

Xamarin   4.4.0.34 (3f99c5a)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   7.2.0.7 (b16fb82)
Visual Studio extension to enable development for Xamarin.Android.

Xamarin.iOS   10.8.0.174 (7656cc6)
Visual Studio extension to enable development for Xamarin.iOS.
Comment 6 Adrian Alonso 2017-06-21 19:48:52 UTC

*** This bug has been marked as a duplicate of bug 57281 ***