Bug 33967 - [Android] Resource files in obj directory are not removed when deleted from Project
Summary: [Android] Resource files in obj directory are not removed when deleted from P...
Status: VERIFIED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild (show other bugs)
Version: unspecified
Hardware: PC Windows
: High critical
Target Milestone: 6.0 (C6)
Assignee: dean.ellis
URL:
Depends on:
Blocks: 33970 33973
  Show dependency tree
 
Reported: 2015-09-15 10:32 UTC by Stephen Shaw
Modified: 2015-09-28 09:59 UTC (History)
3 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Stephen Shaw 2015-09-15 10:32:27 UTC
If there is a theme.xml file in the project and the user deletes it we don't clean/remove it from the obj directory. This causes a problem because the Android Designer parses files in the obj directory to determine which themes or other resources are available.

Steps to reproduce:
1. Create a new simple Android app
2. Open Main.axml (to launch the designer)
3. In the toolbar, click on the paint brush
4. Select Material Palette
5. Select any color (500)
6. Click off of the dialog to go back to the designer
7. Click Save to Current Theme (or whatever the save button save at the time)
8. This should generate a theme.xml file
9. Check that the theme.xml file is in obj/Debug/res/values
10. Delete theme.xml file
11. theme.xml file is still in obj/Debug/res/values

Without testing I'm pretty sure this is also happening on mac and think this is what is causing this bug ->
https://bugzilla.xamarin.com/show_bug.cgi?id=32611
Comment 1 dean.ellis 2015-09-23 10:42:45 UTC
Fixed in monodroid/master/de524175
Comment 2 Abhishek 2015-09-28 09:59:46 UTC
I have checked this issue with the latest master build and latest C6 build Xamarin.VisualStudio_99.0.0.215_641cecb21ab26402057a4242a9f9c81b0f92e36d and 
Xamarin.VisualStudio_4.0.0.1522_c4c44374d79dff874800b549146b1fdb74ae57e2
Now this issue is working fine. 

Here is the screencast for master build: http://www.screencast.com/t/MKwdJUedT

Here is the screencast for C6 build: http://www.screencast.com/t/ItIhuH3QBLTK

Hence closing this issue.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.