This is Xamarin's bug tracking system. For product support, please use the support links listed in your Xamarin Account.
Bug 33764 - Frame outline colour doesn't change using ViewModel
Summary: Frame outline colour doesn't change using ViewModel
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 1.5.0
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Stephane Delcroix
URL:
: 25205 34211 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-09-08 05:59 UTC by Dushyant Bangal
Modified: 2016-03-31 21:34 UTC (History)
8 users (show)

See Also:
Tags: AC ANDROID
Is this bug a regression?: ---
Last known good build:


Attachments
Sample Project (6.39 MB, application/octet-stream)
2015-09-10 01:23 UTC, Dushyant Bangal
Details

Description Dushyant Bangal 2015-09-08 05:59:06 UTC
Steps to reproduce:
1) Bind Frame's OutlineColor to a Color in ViewModel.
2) Change the color on some action.
3) Call OnPropertyChanged.

Actual Result:
Frame Outline disappears or doesn't get changed

Expected Result:
OutlineColor of Frame should change.

Happens in Android, haven't checked for iOS.
Comment 1 Parmendra Kumar 2015-09-08 07:38:16 UTC
I have tried to reproduce this issue and not able to reproduce it. To reproduce this issue I have followed steps mentioned in bug description.

Could you please provide us sample project? so that we can reproduce this issue at our end.


Thanks..!
Comment 2 Dushyant Bangal 2015-09-10 01:23:15 UTC
Created attachment 12842 [details]
Sample Project

I've attached the Sample project for this problem. Clicking on "Change Color" button doesn't do anything.
Comment 3 Parmendra Kumar 2015-09-10 06:00:27 UTC
I tried to reproduce this issue and I am able to reproduce it. To reproduce this issue I have used sample project attached in comment #2.

NOTE: I am getting this issue on Android and its working fine on iOS.

Debug Log: https://gist.github.com/Parmendrak/b6340e9a1a910e9be60e
IDE Log: https://gist.github.com/Parmendrak/e0f5ff46886aed108577

Environment info:

Xamarin.Forms: 1.5.0-pre3
Microsoft Visual Studio Professional 2013
Version 12.0.30723.00 Update 3
Microsoft .NET Framework
Version 4.5.51641
Installed Version: Professional
Xamarin   3.11.894.0 
Xamarin.Android   5.1.6.7 
Xamarin.iOS   8.10.5.0
Comment 4 Rui Marinho 2015-10-15 06:03:20 UTC
Should be fixed in 1.5.2-pre1
Comment 5 Stephane Delcroix 2015-10-15 09:10:43 UTC
not fixed yet
Comment 6 Parmendra Kumar 2015-10-23 14:33:30 UTC
I have checked this issue with X.F 1.5.2-pre1 and its working fine.

Hence closing this issue.
Comment 7 Stephane Delcroix 2015-11-23 07:24:31 UTC
*** Bug 34211 has been marked as a duplicate of this bug. ***
Comment 8 Samantha Houts 2016-03-31 21:34:32 UTC
*** Bug 25205 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.