Bug 33460 - [regression] System.ExecutionEngineException When (De)Serializing Custom Exception
Summary: [regression] System.ExecutionEngineException When (De)Serializing Custom Exce...
Status: RESOLVED NORESPONSE
Alias: None
Product: Runtime
Classification: Mono
Component: JIT (show other bugs)
Version: 4.2.0 (C6)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-08-28 09:59 UTC by Martin Costello
Modified: 2017-10-11 17:03 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Martin Costello 2015-08-28 09:59:50 UTC
Using the latest Mono 4.2.0 alpha release, and unit test that tests round-trip serialization of a custom exception type that was working previously is now failing.

https://travis-ci.org/experiandataquality/electronicupdates/jobs/74706434

The specific error message is:

"System.ExecutionEngineException : Failed to create shadow copy of sibling data (CopyFile).
      Stack Trace:
            at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (System.Reflection.MonoMethod,object,object[],System.Exception&)
         <filename unknown>(0,0): at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture)"
Comment 1 Martin Costello 2015-08-28 10:00:25 UTC
The specific Mono version for this build was:

"Mono JIT compiler version 4.2.0 (explicit/a224653 Mon Aug 17 12:38:55 EDT 2015)"
Comment 2 Marek Safar 2015-08-31 04:22:56 UTC
The exception comes from shadow copying of some file which I am not sure how can be related to custom exception.

Could you make a repro for us to investigate what is actually failing
Comment 3 Rodrigo Kumpera 2015-08-31 11:21:14 UTC
Please provide test instructions on how to reproduce this bug.
Comment 4 Martin Costello 2015-09-01 04:41:34 UTC
To replicate, you can do the following:

  * Install Mono 4.2.0 Alpha on OS X;
  * Clone https://github.com/martincostello/electronicupdates as of commit d70a8eebcdc23183b67c29a6d0d488d2a10132b8;
  * Run ./src/CSharp/MetadataWebApi/build.sh and observe the outcome of the xUnit test 'MetadataApiException_Constructor_For_Serialization_Can_Be_Serialized'.
Comment 5 Martin Costello 2015-09-01 04:49:03 UTC
There's some chatter on a GitHub issue (https://github.com/xunit/xunit/issues/158) which I was seeing whether it was fixed that led me to find this bug which has moved to talking about errors related to shadow copies with AppDomains. Could it be the same root issue?
Comment 6 Marek Safar 2015-09-21 07:37:32 UTC
I cannot reproduce it locally. My output

xUnit.net console test runner (32-bit .NET 4.6.57.0)
Copyright (C) 2015 Outercurve Foundation.

Discovering: MetadataWebApi.Tests
Discovered:  MetadataWebApi.Tests
Starting:    MetadataWebApi.Tests
   Program_MainAsync_Downloads_Data_Files [SKIP]
      No service credentials are configured.
   MetadataApi_GetDownloadUriAsync_Returns_File_Download_Uri_Which_Downloads_Correct_File [SKIP]
      No service credentials are configured.
   MetadataApi_GetAvailablePackagesAsync_Returns_Available_Packages [SKIP]
      No service credentials are configured.
Finished:    MetadataWebApi.Tests

=== TEST EXECUTION SUMMARY ===
   MetadataWebApi.Tests  Total: 22, Errors: 0, Failed: 0, Skipped: 3, Time: 1.369s
Comment 7 Martin Costello 2015-10-01 13:55:10 UTC
I've just re-built the same job in Travis CI and the problem appears to have gone away:

https://travis-ci.org/experiandataquality/electronicupdates/builds/74706428
Comment 8 Rodrigo Kumpera 2017-10-11 17:03:06 UTC
We have not received the requested information. If you are still experiencing this issue please provide all the requested information and reopen the bug report.

Thank you!