Bug 33268 - Picker is broken on Windows 8.1
Summary: Picker is broken on Windows 8.1
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows (show other bugs)
Version: 1.4.4
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: E.Z. Hart [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2015-08-20 13:30 UTC by Riwen
Modified: 2017-03-15 18:03 UTC (History)
10 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments
Reproduction project (384.28 KB, application/x-zip-compressed)
2015-08-21 16:40 UTC, Paul DiPietro [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Riwen 2015-08-20 13:30:24 UTC
Picker modal doesn't show up if the 'Items' list contains 5 or less items. Above that size, it works fine.
Comment 1 Paul DiPietro [MSFT] 2015-08-21 16:40:11 UTC
I've written up a reproduction project which I'll attach that displays the issue in question; it doesn't seem to happen in a Universal Windows project but does for Windows Phone (8.1).
Comment 2 Paul DiPietro [MSFT] 2015-08-21 16:40:31 UTC
Created attachment 12607 [details]
Reproduction project
Comment 3 Jason Smith [MSFT] 2015-12-15 00:02:26 UTC
Should be fixed in 2.0.2-pre1
Comment 4 Rui Marinho 2016-01-20 11:40:45 UTC
Correction should be fixed in 2.1.0-pre1
Comment 5 Pavel Fedotovsky 2016-01-20 11:58:40 UTC
When 2.1.0-pre1 will be released? It's been a month since last release of Xamarin.Forms nuget package.
Comment 6 Rui Marinho 2016-01-20 12:21:36 UTC
Pavel hi, we have lot's of stuff in this release and took a little longer, it should be out this week.
Comment 7 Pavel Fedotovsky 2016-01-20 13:50:51 UTC
Hi Rui, thanks! I can't wait to test a new version :)
Comment 8 Parmendra Kumar 2016-01-27 12:56:11 UTC
I have checked this issue with Xamarin.Forms 2.1.0.6503-pre2 and now its working fine.

Hence closing this issue.
Comment 9 rfreschi 2017-03-13 21:22:22 UTC
I'm still seeing this issue in a Windows Mobile 8.1 project, XF 2.3.3.193

6 items - works fine, selection shows modal page
5 items does not.

Is there a way to force the modal?
Comment 10 E.Z. Hart [MSFT] 2017-03-14 22:18:36 UTC
(In reply to rfreschi from comment #9)
> I'm still seeing this issue in a Windows Mobile 8.1 project, XF 2.3.3.193
> 
> 6 items - works fine, selection shows modal page
> 5 items does not.
> 
> Is there a way to force the modal?

If you run the attached repro project with 2.3.3.193, does the problem occur? If so, are you seeing it in the emulator or on a device? If on a device, what model?
Comment 11 rfreschi 2017-03-15 17:56:33 UTC
Yes the problem is occurring and consistent on an 8.1 emulator, a Windows 10 emulator, and an 8.1 HTC device with the repro project.

I'm using VS 2015 on a Windows 10 machine with latest stable version of Xamarin.
Comment 12 rfreschi 2017-03-15 18:03:07 UTC
The UWP project is working fine. The problem is only with the 8.1 project.