Bug 33218 - Action ReflectedType differs from Delegate ReflectedType
Summary: Action ReflectedType differs from Delegate ReflectedType
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: Reflection (show other bugs)
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Ludovic Henry
URL:
Depends on:
Blocks:
 
Reported: 2015-08-19 06:02 UTC by Piotr Zierhoffer
Modified: 2015-09-09 11:23 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
the failing example (889 bytes, text/x-csharp)
2015-08-19 06:02 UTC, Piotr Zierhoffer
Details

Description Piotr Zierhoffer 2015-08-19 06:02:11 UTC
Created attachment 12568 [details]
the failing example

Compile and run the attached example.

Output on Mono:

Action
======
Reflected type: test35.BaseClass
Declaring type: test35.BaseClass
Attributes: ReuseSlot, Public, Virtual, HideBySig, NewSlot

Delegate
========
Reflected type: test35.DerivedClass
Declaring type: test35.DerivedClass
Attributes: ReuseSlot, Public, Virtual, HideBySig
 


Output on .NET:

Action
======
Reflected type: test35.DerivedClass
Declaring type: test35.DerivedClass
Attributes: PrivateScope, Public, Virtual, HideBySig

Delegate
========
Reflected type: test35.DerivedClass
Declaring type: test35.DerivedClass
Attributes: PrivateScope, Public, Virtual, HideBySig


It appears that this change was introduced by 5ecee9a (Type from referencesources).

Output on Mono a53e977 (== 5ecee9a^):

Action
======
Reflected type: test35.DerivedClass
Declaring type: test35.DerivedClass
Attributes: ReuseSlot, Public, Virtual, HideBySig

Delegate
========
Reflected type: test35.DerivedClass
Declaring type: test35.DerivedClass
Attributes: ReuseSlot, Public, Virtual, HideBySig
Comment 1 Piotr Zierhoffer 2015-09-03 08:08:51 UTC
Actually there is a mistake in my report. The bug was introduced by 611a43ee0f672adbac3e25dc77731843a3d10cf1 [delegate] Replace multicast delegate implementation
Comment 2 Ludovic Henry 2015-09-03 12:08:30 UTC

*** This bug has been marked as a duplicate of bug 32064 ***
Comment 3 Piotr Zierhoffer 2015-09-04 05:11:25 UTC
@Ludovic Henry

As I can't see the 32064 (You are not authorized to access bug #32064), would you be so kind to update the status of this issue, when that one is closed? It is critical for us to know when it is fixed on master.
Comment 4 Ludovic Henry 2015-09-09 11:23:03 UTC
It should be fixed with https://github.com/mono/mono/commit/57be2417161a11335e8bcc74397272629b587f5e

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.


Create a new report for Bug 33218 on Developer Community or GitHub if you have new information to add and do not yet see a matching report.

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments


Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Related Links: